Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT: I gave up on repairing the issue. The reason why is in the comments.

I can't manage to figure out what is preventing me from installing htop. I've tried the tutorial posted here. When I try to install it with sudo apt-get install htop, it returns this:

lubuntu@lubuntu:~$ sudo apt-get install htop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aptdaemon : Depends: python3-aptdaemon (= 1.1.1-0ubuntu3) but 1.1.1-0ubuntu4 is to be installed
             Recommends: lintian but it is not going to be installed
 bind9-host : Depends: libbind9-90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
              Depends: libdns99 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
              Depends: libisc95 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
              Depends: libisccfg90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
              Depends: liblwres90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
 cpp-4.8 : Depends: gcc-4.8-base (= 4.8.1-10ubuntu8) but 4.8.1-10ubuntu9 is to be installed
 cups : Depends: libcups2 (= 1.7.0~rc1-0ubuntu5) but 1.7.0~rc1-0ubuntu5.2 is to be installed
        Recommends: colord but it is not going to be installed
 cups-client : Depends: libcups2 (= 1.7.0~rc1-0ubuntu5) but 1.7.0~rc1-0ubuntu5.2 is to be installed
               Recommends: smbclient but it is not going to be installed
 cups-daemon : Depends: libcups2 (= 1.7.0~rc1-0ubuntu5) but 1.7.0~rc1-0ubuntu5.2 is to be installed
               Recommends: colord but it is not going to be installed
               Recommends: cups-browsed but it is not going to be installed
 dnsutils : Depends: libbind9-90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
            Depends: libdns99 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
            Depends: libisc95 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
            Depends: libisccfg90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
            Depends: liblwres90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is to be installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.38.0-1ubuntu1) but 2.38.1-0ubuntu1 is to be installed
 libunity9 : Depends: libunity-protocol-private0 (= 7.1.2+13.10.20131010-0ubuntu1) but 7.1.2+13.10.20131010-0ubuntu2 is to be installed
 ubuntu-release-upgrader-core : Depends: python3-distupgrade (= 1:0.205) but 1:0.205.4 is to be installed
 ubuntu-release-upgrader-gtk : Depends: ubuntu-release-upgrader-core (= 1:0.205.4) but 1:0.205 is to be installed
 udev : Depends: libudev1 (= 204-0ubuntu18) but 204-0ubuntu19.1 is to be installed
 update-manager-core : Depends: python3-update-manager (= 1:0.194) but 1:0.194.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

apt-get check replies with:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 aptdaemon : Depends: python3-aptdaemon (= 1.1.1-0ubuntu3) but 1.1.1-0ubuntu4 is installed
             Recommends: lintian but it is not installed
 bind9-host : Depends: libbind9-90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
              Depends: libdns99 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
              Depends: libisc95 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
              Depends: libisccfg90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
              Depends: liblwres90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
 cpp-4.8 : Depends: gcc-4.8-base (= 4.8.1-10ubuntu8) but 4.8.1-10ubuntu9 is installed
 cups : Depends: libcups2 (= 1.7.0~rc1-0ubuntu5) but 1.7.0~rc1-0ubuntu5.2 is installed
        Recommends: colord but it is not installed
 cups-client : Depends: libcups2 (= 1.7.0~rc1-0ubuntu5) but 1.7.0~rc1-0ubuntu5.2 is installed
               Recommends: smbclient but it is not installed
 cups-daemon : Depends: libcups2 (= 1.7.0~rc1-0ubuntu5) but 1.7.0~rc1-0ubuntu5.2 is installed
               Recommends: colord but it is not installed
               Recommends: cups-browsed but it is not installed
 dnsutils : Depends: libbind9-90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
            Depends: libdns99 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
            Depends: libisc95 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
            Depends: libisccfg90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
            Depends: liblwres90 (= 1:9.9.3.dfsg.P2-4ubuntu1) but 1:9.9.3.dfsg.P2-4ubuntu1.1 is installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.38.0-1ubuntu1) but 2.38.1-0ubuntu1 is installed
 libunity9 : Depends: libunity-protocol-private0 (= 7.1.2+13.10.20131010-0ubuntu1) but 7.1.2+13.10.20131010-0ubuntu2 is installed
 ubuntu-release-upgrader-core : Depends: python3-distupgrade (= 1:0.205) but 1:0.205.4 is installed
 ubuntu-release-upgrader-gtk : Depends: ubuntu-release-upgrader-core (= 1:0.205.4) but 1:0.205 is installed
 udev : Depends: libudev1 (= 204-0ubuntu18) but 204-0ubuntu19.1 is installed
 update-manager-core : Depends: python3-update-manager (= 1:0.194) but 1:0.194.1 is installed
E: Unmet dependencies. Try using -f.

cat /etc/apt/sources.list{,.d/*.list} replies with:

lubuntu@lubuntu:~$ cat /etc/apt/sources.list{,.d/*.list}
deb cdrom:[Lubuntu 13.10 _Saucy Salamander_ - Release amd64 (20131016.1)]/ saucy main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse





# deb http://ppa.launchpad.net/linrunner/tlp/ubuntu saucy main
# deb-src http://ppa.launchpad.net/linrunner/tlp/ubuntu saucy main
lubuntu@lubuntu:~$ cat /etc/apt/sources.list{,.d/*.list}
deb cdrom:[Lubuntu 13.10 _Saucy Salamander_ - Release amd64 (20131016.1)]/ saucy main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse

sudo apt-get install -f results: Pastebin:

lubuntu@lubuntu:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  aptdaemon bind9-host cpp-4.8 cups cups-client cups-daemon dnsutils
  libglib2.0-bin libunity9 ubuntu-release-upgrader-core udev update-manager
  update-manager-core
Suggested packages:
  gcc-4.8-locales cups-bsd printer-driver-hpcups hplip cups-pdf smbclient xpp
  rblcheck unity-common
Recommended packages:
  lintian colord cups-browsed
The following packages will be upgraded:
  aptdaemon bind9-host cpp-4.8 cups cups-client cups-daemon dnsutils
  libglib2.0-bin libunity9 ubuntu-release-upgrader-core udev update-manager
  update-manager-core
13 upgraded, 0 newly installed, 0 to remove and 91 not upgraded.
2 not fully installed or removed.
Need to get 0 B/8,908 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ... 131819 files and directories currently installed.)
Preparing to replace ubuntu-release-upgrader-core 1:0.205 (using .../ubuntu-release-upgrader-core_1%3a0.205.4_all.deb) ...
Unpacking replacement ubuntu-release-upgrader-core ...
dpkg: error processing /var/cache/apt/archives/ubuntu-release-upgrader-core_1%3a0.205.4_all.deb (--unpack):
 unable to create `/usr/bin/do-release-upgrade.dpkg-new' (while processing `./usr/bin/do-release-upgrade'): Input/output error
No apport report written because MaxReports is reached already
                                                              Preparing to replace update-manager 1:0.194 (using .../update-manager_1%3a0.194.1_all.deb) ...
Unpacking replacement update-manager ...
dpkg: error processing /var/cache/apt/archives/update-manager_1%3a0.194.1_all.deb (--unpack):
 unable to create `/usr/share/man/man8/update-manager.8.gz.dpkg-new' (while processing `./usr/share/man/man8/update-manager.8.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace update-manager-core 1:0.194 (using .../update-manager-core_1%3a0.194.1_all.deb) ...
Unpacking replacement update-manager-core ...
dpkg: error processing /var/cache/apt/archives/update-manager-core_1%3a0.194.1_all.deb (--unpack):
 unable to create `/usr/share/apport/package-hooks/source_update-manager.py.dpkg-new' (while processing `./usr/share/apport/package-hooks/source_update-manager.py'): Input/output error
No apport report written because MaxReports is reached already
                                                              Preparing to replace cups-daemon 1.7.0~rc1-0ubuntu5 (using .../cups-daemon_1.7.0~rc1-0ubuntu5.2_amd64.deb) ...
cups stop/waiting
Unpacking replacement cups-daemon ...
dpkg: error processing /var/cache/apt/archives/cups-daemon_1.7.0~rc1-0ubuntu5.2_amd64.deb (--unpack):
 unable to create `/usr/share/man/man5/classes.conf.5.gz.dpkg-new' (while processing `./usr/share/man/man5/classes.conf.5.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
cups start/running, process 7634
Preparing to replace libunity9:amd64 7.1.2+13.10.20131010-0ubuntu1 (using .../libunity9_7.1.2+13.10.20131010-0ubuntu2_amd64.deb) ...
Unpacking replacement libunity9:amd64 ...
dpkg: error processing /var/cache/apt/archives/libunity9_7.1.2+13.10.20131010-0ubuntu2_amd64.deb (--unpack):
 unable to create `/usr/bin/unity-scope-loader.dpkg-new' (while processing `./usr/bin/unity-scope-loader'): Input/output error
No apport report written because MaxReports is reached already
                                                              Preparing to replace udev 204-0ubuntu18 (using .../udev_204-0ubuntu19.1_amd64.deb) ...
Adding 'diversion of /bin/udevadm to /bin/udevadm.upgrade by fake-udev'
Unpacking replacement udev ...
dpkg: error processing /var/cache/apt/archives/udev_204-0ubuntu19.1_amd64.deb (--unpack):
 unable to create `/usr/share/apport/package-hooks/udev.py.dpkg-new' (while processing `./usr/share/apport/package-hooks/udev.py'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Removing 'diversion of /bin/udevadm to /bin/udevadm.upgrade by fake-udev'
Preparing to replace bind9-host 1:9.9.3.dfsg.P2-4ubuntu1 (using .../bind9-host_1%3a9.9.3.dfsg.P2-4ubuntu1.1_amd64.deb) ...
Unpacking replacement bind9-host ...
dpkg: error processing /var/cache/apt/archives/bind9-host_1%3a9.9.3.dfsg.P2-4ubuntu1.1_amd64.deb (--unpack):
 unable to create `/usr/share/man/man1/host.1.gz.dpkg-new' (while processing `./usr/share/man/man1/host.1.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              Preparing to replace dnsutils 1:9.9.3.dfsg.P2-4ubuntu1 (using .../dnsutils_1%3a9.9.3.dfsg.P2-4ubuntu1.1_amd64.deb) ...
Unpacking replacement dnsutils ...
dpkg: error processing /var/cache/apt/archives/dnsutils_1%3a9.9.3.dfsg.P2-4ubuntu1.1_amd64.deb (--unpack):
 unable to create `/usr/share/man/man1/dig.1.gz.dpkg-new' (while processing `./usr/share/man/man1/dig.1.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace cpp-4.8 4.8.1-10ubuntu8 (using .../cpp-4.8_4.8.1-10ubuntu9_amd64.deb) ...
Unpacking replacement cpp-4.8 ...
dpkg: error processing /var/cache/apt/archives/cpp-4.8_4.8.1-10ubuntu9_amd64.deb (--unpack):
 unable to create `/usr/bin/cpp-4.8.dpkg-new' (while processing `./usr/bin/cpp-4.8'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace cups-client 1.7.0~rc1-0ubuntu5 (using .../cups-client_1.7.0~rc1-0ubuntu5.2_amd64.deb) ...
Unpacking replacement cups-client ...
dpkg: error processing /var/cache/apt/archives/cups-client_1.7.0~rc1-0ubuntu5.2_amd64.deb (--unpack):
 unable to create `/usr/share/man/man1/cancel.1.gz.dpkg-new' (while processing `./usr/share/man/man1/cancel.1.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace cups 1.7.0~rc1-0ubuntu5 (using .../cups_1.7.0~rc1-0ubuntu5.2_amd64.deb) ...
Unpacking replacement cups ...
dpkg: error processing /var/cache/apt/archives/cups_1.7.0~rc1-0ubuntu5.2_amd64.deb (--unpack):
 unable to create `/usr/share/man/man5/mime.convs.5.gz.dpkg-new' (while processing `./usr/share/man/man5/mime.convs.5.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace libglib2.0-bin 2.38.0-1ubuntu1 (using .../libglib2.0-bin_2.38.1-0ubuntu1_amd64.deb) ...
Unpacking replacement libglib2.0-bin ...
dpkg: error processing /var/cache/apt/archives/libglib2.0-bin_2.38.1-0ubuntu1_amd64.deb (--unpack):
 unable to create `/usr/share/man/man1/gsettings.1.gz.dpkg-new' (while processing `./usr/share/man/man1/gsettings.1.gz'): Input/output error
No apport report written because MaxReports is reached already
                                                              Preparing to replace aptdaemon 1.1.1-0ubuntu3 (using .../aptdaemon_1.1.1-0ubuntu4_all.deb) ...
Unpacking replacement aptdaemon ...
dpkg: error processing /var/cache/apt/archives/aptdaemon_1.1.1-0ubuntu4_all.deb (--unpack):
 unable to create `/usr/bin/aptdcon.dpkg-new' (while processing `./usr/bin/aptdcon'): Input/output error
No apport report written because MaxReports is reached already
                                                              Processing triggers for gconf2 ...
Processing triggers for libglib2.0-0:amd64 ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Errors were encountered while processing:
 /var/cache/apt/archives/ubuntu-release-upgrader-core_1%3a0.205.4_all.deb
 /var/cache/apt/archives/update-manager_1%3a0.194.1_all.deb
 /var/cache/apt/archives/update-manager-core_1%3a0.194.1_all.deb
 /var/cache/apt/archives/cups-daemon_1.7.0~rc1-0ubuntu5.2_amd64.deb
 /var/cache/apt/archives/libunity9_7.1.2+13.10.20131010-0ubuntu2_amd64.deb
 /var/cache/apt/archives/udev_204-0ubuntu19.1_amd64.deb
 /var/cache/apt/archives/bind9-host_1%3a9.9.3.dfsg.P2-4ubuntu1.1_amd64.deb
 /var/cache/apt/archives/dnsutils_1%3a9.9.3.dfsg.P2-4ubuntu1.1_amd64.deb
 /var/cache/apt/archives/cpp-4.8_4.8.1-10ubuntu9_amd64.deb
 /var/cache/apt/archives/cups-client_1.7.0~rc1-0ubuntu5.2_amd64.deb
 /var/cache/apt/archives/cups_1.7.0~rc1-0ubuntu5.2_amd64.deb
 /var/cache/apt/archives/libglib2.0-bin_2.38.1-0ubuntu1_amd64.deb
 /var/cache/apt/archives/aptdaemon_1.1.1-0ubuntu4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm completely lost. There's so much here I can't comprehend what I did to make this happen.

Attempted:

  • apt-get update --fix-missing then apt-get -f install
  • The tutorial linked above.
share|improve this question
    
@Braiam I added the information. –  5rock4 Mar 2 at 23:28
    
Post the output of sudo apt-get install -f –  Avinash Raj Mar 3 at 1:33
    
@karel I tried that. Didn't work –  5rock4 Mar 3 at 1:44
    
@AvinashRaj Edited the post to add the results. –  5rock4 Mar 3 at 1:56
1  
@Braiam I should have edited the question: at one point, I restarted the OS and it (even though it was a live USB with a persistent file size) gave me a login prompt which made me login to an account I never created. I had to make an account using the virtual terminals (Alt + Ctrl + F2). sudo still worked. When I got into Lubuntu's main screen, a ton of crash reports open in a foreign language. I have no idea what it was but, I decided it was F.U.B.A.R. and not worth trying to repair. I'm going to format the USB and start again from scratch with Ubuntu Gnome. Thanks for the help. –  5rock4 Mar 3 at 16:53

1 Answer 1

apt-get update --fix-missing
apt-get -f install

The solution to this problem was in the text you posted :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.