Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Xubuntu 13.10 64 bit. This question tells you everything you need to know about my graphic card.

Yesterday I had a problem, my graphic card driver failed, now if I login to xubuntu default desktop, all I see is a black screen however I can login to xfce session

The output of inxi -G:

Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller 
           Card-2: Advanced Micro Devices [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] 
           X.Org: 1.14.5 drivers: fglrx,intel Resolution: 1366x768@60.0hz 
           GLX Renderer: AMD Radeon HD 6400M Series GLX Version: 4.2.12337 - CPC 13.101

enter image description here

enter image description here

xsession-errors

Script for cjkv started at run_im.
Script for default started at run_im.
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Xsession: X session started for elie at Mon Mar 10 10:16:26 EET 2014
localuser:elie being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Script for cjkv started at run_im.
Script for default started at run_im.
Script for cjkv started at run_im.
Script for default started at run_im.
libGL error: failed to load driver: i965
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
gnome-session-is-accelerated: llvmpipe detected.
x-session-manager[2113]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Xsession: X session started for elie at Mon Mar 10 10:17:23 EET 2014
localuser:elie being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Script for cjkv started at run_im.
Script for default started at run_im.
Script for cjkv started at run_im.
Script for default started at run_im.
libGL error: failed to load driver: i965
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
gnome-session-is-accelerated: llvmpipe detected.
x-session-manager[2466]: CRITICAL: We failed, but the fail whale is dead. Sorry....

/var/log/Xorg.0.log.old and /etc/X11/xorg.conf. Note that I no longer have xorg.conf, because I followed the answers below, but even if I generate new file, It will be looking like the file above, I tried it.

share|improve this question
    
Very strange. Try sudo apt-get install -f, then sudo apt-get purge jockey-gtk followed by sudo apt-get install jockey-gtk. Does Additional Drivers work now? –  landroni Mar 11 at 15:40
    
@landroni no still the same error –  Fischer Mar 11 at 22:13
    
What does whereis jockey-gtk output? –  landroni Mar 11 at 22:15
2  
Yes, looks like it. It also looks like the module is both working an loaded. OK, try logging into the default session again, and then post the contents of ~/.xsession-errors, that will tell us what error you are experiencing. You might also want to remove all the stuff about jockey-gtk since it's not relevant and you now know how to access jockey's functionality. Even better, come into the chat room where we can discuss more easily. –  terdon Mar 12 at 13:00
1  
@Rmano I updated my question, I'll try to follow your answer and get back to you, the proprietary drivers were working fine on my PC, until that problem. if it doesn't work, it's okay 14.04 is coming in less than a month and I'm going to install it anyway so no big deal, but it would be great if the issue can be fixed –  Fischer Mar 17 at 19:07

4 Answers 4

Your xorg.conf has two device sections:

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "intel"
    Driver      "intel"
    Option      "AccelMethod" "uxa"
EndSection

This is causing your machine to attempt to load both the fglrx and the intel drivers. While it is actually possible to use multiple graphics cards on Linux, I doubt you can do that with an integrated (intel) and a dedicated (ATI) one. It is very likely that removing the intel section will return everything to normal (assuming the fglrx driver works on your system but as I understand it used to, so it probably will). So, comment out the intel section and keep only fglrx:

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

#Section "Device"
#    Identifier  "intel"
#    Driver      "intel"
#    Option      "AccelMethod" "uxa"
#EndSection

Then restart X and, assuming there is no other issue, everything should be fine.

If not, you can try creating a new xorg.conf using ATI's configuration tool, aticonfig:

sudo aticonfig --initial

If you do go down this road, I also recommend you read through that program's options, they're quite extensive:

aticonfig --help | less

Finally, the Arch wiki page on ATI/AMD cards is a great source of information on this kind of thing.

share|improve this answer
    
sorry for the late reply, commenting these lines will cause ubuntu to boot into tty –  Fischer Mar 14 at 16:28
    
@Fischer damn, something very strange in your setup. OK, try the aticonfig apporach, also try commenting out the fglrx section and using the intel one instead. Your system seems to be confused about which card to use. Finally, check your BIOS settings, which card is activated there? Do you have it set to software switching? –  terdon Mar 14 at 16:32
    
So far I have tried sudo aticonfig --initial, it created xorg.conf similar to the one I have so the issue is still there, I will try to comment fglrx, btw I enter bios and I see nothing about my graphic card, there's stuff like the serial number of the pc, the wireless module, nothing about the graphic card, I'm on hp pavillion g6 –  Fischer Mar 14 at 19:50
    
I tried to comment out fglrx did not work –  Fischer Mar 14 at 20:08
    
@terdon, he has an hybrid card; it's quite common on recent laptops and a PITA in Linux most of the time :-| --- I know, I have one that make the installation disk of Ubuntu overheat and shutdown the system in seconds. –  Rmano Mar 17 at 19:19

Try to purge the GC drivers and reinstall:

sudo apt-get purge fglrx fglrx-pxpress

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install fglrx fglrx-pxpress

If that doesn't fix it, time to edit XConfigs!

share|improve this answer
    
Didn't work, and this is the output if you want to see it hastebin.com/talitexeru.vhdl –  Fischer Mar 11 at 22:27
3  
After the purge, you have to manually remove /etc/X11/xorg.conf file. It is not deleted automatically... that solved my problem when going back to open-source drivers. –  Rmano Mar 12 at 15:57
    
@Rmano tried that yesterday again, did not work –  Fischer Mar 16 at 8:58

I think you could try to uninstall first your third-party driver. Then try deletesudo rm /etc/X11/xorg.conf and reboot. XSERVER will create a new one.

share|improve this answer
    
tried that yesterday again, did not work –  Fischer Mar 16 at 9:00
    
Could you post a video link with the start up sequence? –  Finn Krauß Mar 16 at 10:14
    
nothing worth filming, normal booting no errors, after logging in i see imgur.com/nSsgpCm –  Fischer Mar 16 at 13:22
    
To go back to open source drivers, you have to purge fglrx and fglrx-pxpress to (or they -update equivalent). –  Rmano Mar 17 at 18:17

A shot in the dark --- let's suppose is not the graphic drivers. What is failing seems to be the x-session-manager script, due to a bug in libGL.

So I would try:

1) calling manually startx in a terminal. If the graphic screen appears, the drivers are working ok, and the problem is somewhere else. (You'll probably have just one naked terminal in it).

2) Try to reconfigure gdm or lightdm. By the way, I could not start xubuntu desktop with lightdm windows manager, I had to install gdm. So could be

sudo dpkg-reconfigure gdm 

And/or the corresponding sudo apt-get install gdm if you do not have it.

3) going deeper, it may be the 3D graphics failing. Have you installed xorg-edgers or something like that? Maybe it is a recent bug in it.

4) and as a last resort, you can try some non-accelerated desktop, like Gnome classic or Ubuntu 2D.

5) Try to login as a guest user to see if the problem is related to some strange configuration file.

6) and as a voodoo-kind of thing: check is there is some strange dot file (with ls - lad .*) owned by root stick in your home dir --- I once had a $DEITY-know-how-was-there .Xauthority file owned by root that blocked all my logins...

Hope this helps... but probably not.

share|improve this answer
    
sudo startx will give a black screen so I'd have to go to tty to restart gdm, does that mean it's a graphic card issue? –  Fischer Mar 17 at 19:49
    
And if you restart gdm you have a login screen? –  Rmano Mar 17 at 19:52
    
yes if i restart gdm i have a login screen, lightdm doesn't work –  Fischer Mar 17 at 19:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.