Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This question already has an answer here:

I am trying to use OpenGL on my Ubuntu 12.04 LTS. I installed OpenGL with the following commands:

sudo apt-get install g++ cmake
sudo apt-get install freeglut3 freeglut3-dev
sudo apt-get install binutils-gold

I wrote a simple example in C++ and compiled it with g++ -lGL -lglut main.cpp -o test and then I tested it using ./test. A window opened but it was black and I didn't show anything. So, I installed my nvidia driver using the following commands:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-current
sudo apt-get install nvidia-settings
sudo reboot

And now when I try to run again the program it gives me the 2 errors:

Xlib:  extension "GLX" missing on display ":0".
freeglut (./test): OpenGL GLX extension not supported by display ':0'

What could be the problem?

Also, here is the output of the lspci | grep VGA command:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
share|improve this question

marked as duplicate by Eric Carvalho, Mitch Jul 23 at 17:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
What graphics card do you have? Can you also paste /var/log/xorg.0.log to paste.ubuntu.com and drop a link here? Thanks. –  Seth Mar 2 '14 at 18:25
    
Nvidia; here is the link paste.ubuntu.com/7023355 –  user1956190 Mar 2 '14 at 18:32
    
What Nvidia? Do you have an Intel card too? What is the output of lspci | grep VGA? (please edit it into your question). –  Seth Mar 2 '14 at 18:36
    
I have edited my question. What could be wrong? –  user1956190 Mar 3 '14 at 11:07
    
Normally that message indicates a graphic driver without proper 3D support. What is the output of glxinfo | grep vendor if it is NVIDIA Corporation you activated the proprietary nvidia driver. –  user3793747 Apr 7 at 0:13

1 Answer 1

Now it is all upcoming by those dual-boot-installations that Ubuntu is depending on long-life of hardware and due to hybrid mainboards it is playing a role, if users simply leave out dual-boot with windows, wine and samba and simply then should try a more minimal installation like described here below of myself (this is really playing a role and some deciding persons have overseen this since upcoming efi and uefi bios-chips before 2012) :

How do I enable Ubuntu (using full disk encryption) to call LUKSsupend before sleeping/suspending to RAM?

Then combine this with this solution here ? + simply check it :

"monitor brightness down" key resets brightness before lowering it

;o)

share|improve this answer
1  
This is an answer for OPs question? I understand nothing. –  A.B. Jul 16 at 4:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.