Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been struggling now for an inordinate amount of time trying to get the brightness adjustment working in Ubuntu.

I am running Ubuntu 12.04 on a Lenovo V570 Laptop.

I have tried all of the adjustments I can find to "fix brightness control" in the /etc/default/grub file with the following results (before you ask, yes I did run sudo update-grub and sudo reboot after each change):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Result: No response to buttons, slider has no affect.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Result: No response to buttons, slider has no affect.

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_osi='!Windows 2012'"

Result: Limited response to buttons from OS (slider only moves down one tick, then sticks), no dimming, slider has no affect.

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet" Result: OS responds to buttons, but screen does not dim. Slider has no affect.

Am I missing something? What can I do to adjust the brightness?

Update: I did more searching, and I found that in /sys/class/backlight I have both acpi_video0 and intel_backlight. By changing the "brightness" file in each of these folders, I discovered, that editing the /sys/class/backlight/intel_backlight/brightness changed the actual brightness setting on my screen. How do I get Ubuntu to adjust this setting? Any hope of getting my function keys to also adjust it?

Update2:

As requested, here is the output from lspci:

    $ lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
share|improve this question

1 Answer 1

I was also suffering from same problem,but I found here a solution that worked for me(on Acer Aspire-5738).

If you have acpi_video0 and /sys/class/backlight/intel_backlight/brightness and changing /sys/class/backlight/intel_backlight/brightness is changing your computer brightness , you can force your system to use intel_backlight.

  • Create a file 20-intel.conf in /usr/share/X11/xorg.conf.d/ using following command:

    gksudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

  • Now paste this

    Section "Device" Identifier "card0" Driver "intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

  • Save and logout.

share|improve this answer
    
I just attempted this, to no avail. After rebooting, I tried again to use the slider and the function keys to alter brightness. Neither had any affect. –  Bts Mar 2 at 17:29
    
you can use sudo tee sys/class/backlight/intel_backlight/brightness command temporarily to change your brightness using terminal or you can create a simple script having #/bin/bash sudo tee /sys/class/backlight/intel_backlight/brightness, make it executable and use it until a working solution is not found.. –  Guru Mar 2 at 17:39
    
Right, I am able to do it manually by using the method you mentioned. Are you saying that it is not possible to use the slider and/or function keys at this time? –  Bts Mar 2 at 17:42
    
Can you post the output of lspci | grep VGA. BusId in the above solution may need to change according to output. –  Guru Mar 2 at 18:23
    
See 'Update 2' above. –  Bts Mar 2 at 19:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.