Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I really don't get it, my wifi worked fine when I booted from dvd but after installing ub 12.04 my wifi only detects all APs but I suddenly can't connect to any of 'm and my neighbor upstairs and me are sharing his broadband connection (So I can only connect to the internet via Wifi and not by cable)

I'm so pissed off, I donated $25 when I was asked for a donation before downloading ub 12.04, because of the "good" first impression I got from the trial I thought, why not, it works fine Which it DID until I installed ub 12.04 and got stuck, I'm writing this on a damn tablet, ain't that great? How can I download necessary drivers if I can't get my pc connected?

I have a sweex rt73 and a built in wifi adapter Ralink technology corp 802.11n wireless lan card, but i'd rather not use the built in card because I have a much better signal on the sweex rt73 wifi stick

I also tried tethering my pc with a tablet but after a few seconds ub disconnects the usb connection to the tablet, so no network there either

share|improve this question
    
I installed windows again and here's the info on my wifi adapters: 9sry for the messy looking list but for some reason i cannot start a new line by pressing enter. When I press enter my comment gets posted rightaway and I am only allowed to edit) Built in netw card: 802.11n Wireless LAN Card PCI\VEN_1814&DEV_3062 PCI bus 5, device 5, function 0 Ralink Technology, Corp. Usb wifi stick: RT73 USB Wireless LAN Card USB\VID_148F&PID_2573 Port_#0002.Hub_#0007 Ralink Technology Corp. To me it doesn't look really useful, but what do I know, right? –  user253802 Mar 2 at 14:01

1 Answer 1

I suspect the drivers for your two devices are conflicting. I suggest you blacklist the driver for the internal device. Please open a terminal Ctrl+Alt+t and do:

sudo -i
echo "blacklist rt2800pci"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r rt2800pci
exit

The RT73 device may work perfectly now; if not, check the logs for useful clues:

dmesg | grep rt7

If it complains about missing firmware, please check here: rt73.bin for Ubuntu 12.04 LTS?

share|improve this answer
    
tHANKS, i'LL DO THAT WHEN i CAN BOOT THE uB PARTITION (sry caps). Suddenly I can't boot UB anymore. Bios sees the UB drive in post but I can't set it as Boot drive. It's a 2.3 TB drive. When I press F11 during post it's not listed as potential boot device. When I know where i want to install UB again, a workaround is making 2 partitions on 2.3 TB drive, I didn't buy a high volume storage device to partition it as 2 much cheaper <2.0 TB HDDs. I'll post results but it may take a while, RL obligations. I spent 3 days to get PC back to before it went nuts, I feel like gaming. But " I'll be back" –  user253802 Mar 2 at 23:26
    
We'll be here to help when you're ready! –  chili555 Mar 3 at 1:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.