Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried changing my refresh rate in Compiz but that didn't work. It's just so slow and choppy you wouldn't believe. I know it's not my graphics card because before I installed Ubuntu I had Windows XP and it was fine. Any ideas?

00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02)

That's my graphics card.

share|improve this question
Are you using 64bit ubuntu? – zookalicious May 15 '11 at 0:20
No 32bit Ubuntu. – Earl Larson May 15 '11 at 3:15

Issues such as these needs a few bits of information:

  1. need further information such as your graphics card and whether you have activated any graphics drivers in the Additional Hardware Window.

To find out what your graphics card is copy and paste the following into a terminal:

lspci | grep VGA

Assuming that you are using Firefox, try adding the Flash-Aid addon

If you are using Chrome/Chromium can you reproduce the issue with Firefox + Flash-Aid?

  1. Confirm whether this is a Compiz issue or not. Logout of Unity and choose the Ubuntu (Classic) and confirm whether the issue still occurs.

  2. What's the quality of the Flash Video you are attempting to watch. HD quality flash videos are rarely achieved unless you have the newer ATI/NVIDIA cards & with their proprietary drivers installed.

  3. Some people have reported issues on upgrading - these graphics issues sometimes "resolve themselves" if a new user account is created and used.

Since you have confirmed that its an Intel and the its still an issue in "no effects" - then that leaves the flash-video quality. If you have an issue with standard 240/360 Flash Videos, then its more likely to be the intel driver. Suggest file a bug report on Launchpad.

Also double check Firefox + Flash-Aid, and whether a new account resolves.

share|improve this answer
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02) – Earl Larson May 14 '11 at 22:41
And I'm using Chrome – Earl Larson May 14 '11 at 22:41
Try logging out and choosing Ubuntu Classic (No Effects) - do you have the same/similar issues? – fossfreedom May 14 '11 at 22:50
Yeah, it's still choppy. – Earl Larson May 14 '11 at 22:53

First of all check if you are using the latest version of flash. I myself had a lot of problems with flash before version 10.2 came out.

If you already have the newest version of Flash, there could be a problem with you graphic card drivers. Unfortunately you haven't specified which graphic card you are using and which drivers you have installed so I can't really help you yet.

share|improve this answer
I'm using Chrome so yes I'm using the latest. If you could point me to where my graphics card's name is maybe you could help me more? :) – Earl Larson May 14 '11 at 22:36
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02) – Earl Larson May 14 '11 at 22:41

I solved tweaking my xorg.conf by doing a research on google based on ati video cards as mine has an ATI chipset.

This is what I added.

Section "Device"
    Identifier    "Configured Video Device"
    Option "AGPMode" "4"
    Option "AGPFastWrite" "True"
    Option "EnablePageFlip" "True"
    Option "AGPMode" "4"
    Option "AGPSize" "64"
    Option "RingSize" "8"
    Option "BufferSize" "2"
    Option "EnableDepthMoves" "true"
    Option "RenderAccel" "true"
    # Eyecandy Stuff
    Option "AccelMethod" "XAA"
    Option "EnablePageFlip" "true
    Option "DDCMode"
    Option "SubPixelOrder" "NONE"
    Option "ColorTiling" "false"
    Option "MigrationHeuristic" "greedy"
    Option "DynamicClocks" "on"

Problem is gone.

share|improve this answer
please include where and how this was done – Ringtail Nov 17 '12 at 3:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.