Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem with sharing of folders with the host. I have an Ubuntu 13.10 installed on VMware Workstation 8. I have Windows 8 as host. I tried almost every possible solutions available but I did not get any result.

The first thing I tried is enabling the Shared Folder in the Settings of VMware but when I checked my cd /mnt/hgfs directory, I did not see the newly created folder.

The second thing I tried is sudo vmware-config-tools.pl and updated my fstab gksu gedit /etc/fstab and added this line: .host:/LogFiles /media/SharedFolder vmhgfs defaults,ttl=5,uid=1000,gid=1000 0 0 with the LogFiles as the folder I shared in the Settings>Option>Shared Folder

I also tried updating my vmware tools.

Third thing I tried:

  1. Install open-vm-tools

    sudo apt-get install open-vm-tools

  2. Create mount point for shared folders

    mkdir /media/SharedFolder

  3. Go to the scripts services directory:

    cd /etc/init.d

  4. Create script to load at the boot time (if you prefer you can use nano instead of vim):

    sudo vim mountshfolder #!/bin/bash # load vmhgfs kernel module modprobe vmhgfs # mount vmware share folder mount -t vmhgfs .host:/LogFiles /media/SharedFolder exit`

  5. Give executable permission to the script:

    sudo chmod a+x mountshfolder

  6. Set the script to be execute for all runlevels:

    sudo update-rc.d mountshfolder defaults

and it successfully created a folder in my Desktop (Windows 8) with the folder name Ubuntu Shared Folder and I checked my media and found that there is "SharedFolder" folder created but when I tried putting text files inside it, it doesn't appear in my Ubuntu Shared Folder in my Desktop (host).

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.