Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble with the wireless card on my mom's acer aspire 4310.. I got her to use linux on her old toshiba and she wants it on this Acer too but I'm having trouble getting the wireless to work.. I am currently connected via ethernet..

Here is the lspci output

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
03:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
0a:06.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
0a:06.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
0a:06.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)

And this is what rfkill all says

0: acer-wireless: Wireless LAN     Soft blocked: no    Hard blocked: no

At first it was soft blocked then I ran rfkill unblock wifi but it still won't work! There are no wireless networks in the panel and the system settings only shows the ethernet connection... I have installed the sta drivers and that didn't help either.. any ideas?

Additional details: fresh ubuntu 13.10 install and fully updated

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Your Broadcom 4311 needs firmware and to have the STA driver removed. Please get a temporary wired ethernet connection, open a terminal and do:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree

Detach the ethernet, reboot and tell us if it is working.

share|improve this answer
    
no good yet, no wireless networks shown, I don't think the system knows it is wifi-enabled... when I detach the ethernet I just see the empty wifi symbol and clicking it shows greyed out stuff.. –  Lucas Feb 28 at 17:44
    
MY BAD! It WORKS NOW!! Turns out the command got rid of the bcmwl-kernel-source package but I had to get rid of two additional STA packages I installed hoping they would help. I entered sudo apt-get purge broadcom-sta-source and then the same with broadcom-sta-common.. thanks a lot!! –  Lucas Feb 28 at 17:55

I have an Acer Aspire 4752 and I had a similar problem. I found that I must turn on wireless with the physical switch everytime I turn on the computer. The physical switch is accessed using the blue Fn key and one of the function keys at the top. On mine it's F3. I have to hold it down and push it 1 - 3 times before the wireless will turn on. I suggest clicking on your wireless icon in the task bar so you can see it's status, then turning on the wireless at the switch. If you press the switch, release it when you see the wireless icon change.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.