Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

To start off in case that makes any difference: I am doing this from a live-usb-stick of 13.10 to check if everything works before actually installing Ubuntu and leaving Windows behind.

Printing on a network printer

I print via network but the print server only accepts certain usernames. The 'ubuntu' username obviously isn't one of them.

As being forced to call the ubuntu user the same as the user allowed for printing is just a dirty workaround (which I didn't try but assume would work) I looked for a solution, but I didn't find any option to manually set a username in the GUI. So I googled.

Changing the user

I found this bug report #856776 via Use different username on CUPS remote printing

When printing with lp -U username -d printername file.ext everything works.

On the last comment of this issue I found what I believe to be a solution namely adding a directive in client.conf to force the username to something different.

But I couldn't make this work:

  • /etc/cups/client.conf doesn't exist
  • when I create ~/.cups/client.conf and add User bob this doesn't help

I am pretty new to Ubuntu and maybe there is something I forgot. Restart something? Add something else? How can I make this work?

share|improve this question

I believe I solved your problem, my answer is here. Short version: set the "billing info" in the "print menu/jobs".

share|improve this answer
I'll try this and report back if it helps. – kraftner Jul 14 '14 at 11:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.