Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Java 7 and later I got troubles with my system, I can't update anymore. The package system is broken.

Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal:

  1. sudo dpkg --check ==> no results, does not recognise command

  2. sudo apt-get check

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     libc6 : Depends: libgcc1 but it is not installed
             Depends: tzdata but it is not installed
    E: Unmet dependencies. Try using -f.
    
  3. apt-cache policy debconf

    debconf:
      Installed: (none)
      Candidate: 1.5.42ubuntu1
      Version table:
         1.5.42ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages
    
  4. apt-get install -f

    The following packages have unmet dependencies:
    libc6: Depends: libc-bin (= 2.15-0ubuntu10.5) but 2.15-0ubuntu10.5 is installed
           Depends: libgcc1 but it is not installed
           Depends: tzdata but it is not installed
    
    sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      apt-utils coreutils debconf debconf-i18n dpkg libacl1 libapt-inst1.4
      libapt-pkg4.12 libattr1 libbz2-1.0 libdb5.1 libgcc1 liblocale-gettext-perl
      liblzma5 libselinux1 libstdc++6 libtext-charwidth-perl libtext-iconv-perl
      libtext-wrapi18n-perl perl-base tar tzdata xz-utils zlib1g
    Suggested packages:
      debconf-doc debconf-utils whiptail dialog gnome-utils
      libterm-readline-gnu-perl libgtk2-perl libnet-ldap-perl libqtgui4-perl
      libqtcore4-perl apt bzip2 ncompress xz-lzma
    The following NEW packages will be installed:
      apt-utils coreutils debconf debconf-i18n dpkg libacl1 libapt-inst1.4
      libapt-pkg4.12 libattr1 libbz2-1.0 libdb5.1 libgcc1 liblocale-gettext-perl
      liblzma5 libselinux1 libstdc++6 libtext-charwidth-perl libtext-iconv-perl
      libtext-wrapi18n-perl perl-base tar tzdata xz-utils zlib1g
    0 upgraded, 24 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/9303 kB of archives.
    After this operation, 29.7 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_TIME = "de_CH.UTF-8",
        LC_MONETARY = "de_CH.UTF-8",
        LC_ADDRESS = "de_CH.UTF-8",
        LC_TELEPHONE = "de_CH.UTF-8",
        LC_NAME = "de_CH.UTF-8",
        LC_MEASUREMENT = "de_CH.UTF-8",
        LC_IDENTIFICATION = "de_CH.UTF-8",
        LC_NUMERIC = "de_CH.UTF-8",
        LC_PAPER = "de_CH.UTF-8",
        LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_ALL to default locale: No such file or directory
    E: Cannot get debconf version. Is debconf installed?
    debconf: apt-extracttemplates failed: No such file or directory
    dpkg: regarding .../libgcc1_1%3a4.6.3-1ubuntu5_i386.deb containing libgcc1, pre-dependency problem:
     libgcc1 pre-depends on multiarch-support
      multiarch-support is unpacked, but has never been configured.
    dpkg: error processing /var/cache/apt/archives/libgcc1_1%3a4.6.3-1ubuntu5_i386.deb (--unpack):
     pre-dependency problem - not installing libgcc1
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     /var/cache/apt/archives/libgcc1_1%3a4.6.3-1ubuntu5_i386.deb
    E: Internal Error, No file name for libc6
    W: Could not perform immediate configuration on 'multiarch-support:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
share|improve this question
    
Does a sudo apt-get install -f do anything? – Ross Feb 28 '14 at 14:52
    
added the apt-get install -f results – user233269 Feb 28 '14 at 14:55
    
Did you erase any packages before running that command? It looks like the package manager is missing quite a few crucial packages. – Ross Feb 28 '14 at 15:17
    
yes, I did, before installing java 7, I executed a terminal command to help me install serviio, but that was a command for Fedora and not ubuntu. – user233269 Feb 28 '14 at 15:19
    
Ah, okay. How exactly did you install Java? – Ross Feb 28 '14 at 15:20

If coreutils is not installed, your system is seriously hosed.

Does /bin/date exist and work? If yes, “just” your package database is corrupt. In this case, restore /var/lib/dpkg/status from a backup – e.g. /var/lib/dpkg/status-old or one of the files /var/backups/dpkg.status.* (remember to uncompress the *.gz files).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.