Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 with Saucy HWE and Nvidia 331.20 with GeForce 310. I have two identical 1440x900 displays. Nearly each time I resume from suspend, I have to detect displays to get my 2nd display to come back. Sometimes I have to press the button several times and sometimes I get unknown display for the second display and the resolution is at 640x480 until I press detect displays a few more times.

The primary display is connected with dual link DVI, and the second display is connect with single link DVI adapter to display port on the graphics card.

Is this normal, or does anyone have any suggestions?

share|improve this question

2 Answers 2

I had a similar problem with an older nvidia card. For me this was fixed by configuring my screens in nvidia-settings-manager instead of ARandR.

share|improve this answer
    
You put me on the right path! I found more of the info I needed here: askubuntu.com/questions/456470/… –  HarlemSquirrel May 9 at 13:28
up vote 0 down vote accepted

I had the same issue in Ubuntu 14.04 using Nvidia 331.38 and was able to fix it by running sudo nvidia-settings while both screens were working, selecting the "X Server Display Configuration" tab, clicking the "Save to X Configuration File" button, and saving to /etc/X11/xorg.conf

Now I can suspend and resume with both screens coming back!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.