Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

...programs run normally, but the effects are very sluggish. How can I fix this?

share|improve this question
3  
Well... you could start by adding some detail to your question :D! –  RolandiXor May 14 '11 at 14:51

3 Answers 3

Disable Detect Refresh Rate, and Sync To Vblank

  • Install CompizConfig SettingsManager by running the following command in a terminal:

    sudo apt-get install compizconfig-settings-manager

  • Launch it by searching from the dash in Unity, or find it under Preferences > CompizConfig Settings Manager in Ubuntu Classic.

  • Click on the Composite tab, and un-check Detect refresh rate.

enter image description here enter image description here

  • Click on the OpenGL tab, and un-check Sync to Vblank.

enter image description here enter image description here


Install drivers for your Graphics Processing Unit

  • Open Additional Drivers by searching from the dash in Unity, or find it under Administration > Additional Drivers in Ubuntu Classic.

  • Install/Activate any available drivers for your GPU. enter image description here

share|improve this answer

Check to see if you're using your graphics card to its potential

you may need to install mesa-utils

do glxinfo | grep rendering

you should see Direct Rendering: Yes

In your cause hopefully it will say no which means that you need to install the proper drivers for your video card.

share|improve this answer

If you are using the newest Ati propriety drivers the problems could be the Tear Free Desktop setting.

Go to the Catalyst Control Center and find Tear Free under the Display Options and disable it.

This is what was causing sluggish effects on my machine, but because you didn't give us much detail on your problem, this answer is just a blind shot...

share|improve this answer
    
I did it, there is no change... –  alem May 15 '11 at 13:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.