Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question might sound crazy, and maybe it is. My folder share can only be accessed through the ip address which corresponds to my wireless adapter. If someone tried to access the share through the ip address which corresponds to the wired adapter, they won't see it.

I have a samba share set up like the following:

[MyShare]
    path = /media/MyShare
    available = yes
    writeable = yes
    browsable = yes
    guest ok = yes
    read only = no
    create mask = 0755

The global section contains

wins support = yes

Recently I have had to disable my wireless adapter. Unfortunately, there is no longer a way to access this share. I was under the impression samba would allow access through any network connection. Does anyone know the reason for this behavior? Do I need to explicitly tell Samba which IP address or network adapter it should be using?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You can specify which adapter samba can bind :

in /etc/samba/smb.conf

add the following under global section :

[global]
    interfaces =  ( choose your adapter maybe wlan0 )
    bind interfaces only = yes

The interface you write will be used by samba , you can specify more than one Adapter.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.