Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, long story short my Asus P8Z77-v Pro died on Sunday (the second one I've had die) so I got myself an AsRock P77 Extreme4 to tide me over/replace it.

Problem is that when I goto install my NVIDIA Proprietary Drivers Ubuntu cannot find any. The 'Additional Drivers' searches and finds nothing.

I have Downloaded the Latest directly from NVIDIA to try a manual install tonight but I'd rather have this simple and useful feature work. Does anyone know how to troubleshoot this?

Side note: I used the same Flash disk to install 13.10 and everything else seems to work, even the 2 displays coming off of this gfx card, just not using decent drivers that support OpenGL etc...


share|improve this question
Only difference between this system and what I had before Sunday is the Mainboard. That's all. – Noki Feb 27 '14 at 17:49

The easiest way would be to directly install nvidia-current package from the repository. You can also try

apt-get update --fix-missing

to fix any repository mismatches, in case that happened and that's why the additional driver software can't find you the driver you want.

share|improve this answer
Just tried that, no errors on install. But now after grub I get a black low res screen and a cursor, that's all seems it's more than just a missing driver. Thanks though that is useful to know! – Noki Feb 27 '14 at 20:00
And recovery mode to autoremove nvidia-current give two full res screens but both black and with a cross as the cursor. – Noki Feb 27 '14 at 20:07
up vote 1 down vote accepted

So, after many failed attempts with varying results I have FIXED this problem. I at one point managed to get my NVIDIA drivers installed manually whilst breaking half of Ubuntu. It did however work well enough to login running the proprietary drivers so I knew it would work.

Annoyingly the eventual solution was rather simple, annoying since it's taken all my free time this week when I could have fixed it in 3 minutes.

The Fix

After a fresh install of 13.10 do the following:

jockey-text -l

Shows a list of drivers that should show up in the Additional Drivers menu option. Then I ran the 'activation' for the top item:

sudo jockey-text -e kmod:nvidia_319_updates

2 minutes later and BAM it worked!

It still fails to find additional drivers in the system settings menu, or even show that I am currently running one. But this is definitely fixed! :)

Thanks to:

How can I reconfigure the nvidia proprietary drivers from the command line (ssh)?


share|improve this answer
That's just frustratingly simple. Thanks for posting this. – aroll605 Mar 1 '14 at 16:27
Indeed! With a clear head I looked at the problem differently, not how do I install the drivers manually, instead how do I fix/workaround jockey. – Noki Mar 1 '14 at 17:35
jockey-common is now surpassed by ubuntu-drivers in 14.04. I have logged a bug:… – Noki Apr 24 '14 at 19:38
Now fixed in Ubuntu 14.04. – Noki Jul 1 '14 at 22:54

I was able to solve this problem on Ubuntu 14.04 by installing the xorg-edgers ppa:

sudo add-apt-repository ppa:xorg-edgers/ppa -y
sudo apt-get update

The drivers now show up under the additional drivers tab.

You can determine which driver to install by visiting and filling in the details about your graphics card and system.

share|improve this answer
This was fixed in later versions for me, plus since I have switched to manually installing them.… – Noki Jun 12 '15 at 13:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.