Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Java is not working on Google Chrome in Ubuntu 12.04. How can I enable it?

share|improve this question

marked as duplicate by Braiam, Jorge Castro, belacq, guntbert, karel Feb 28 at 0:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Do you want to enable java on google chrome or chromium browser? –  Avinash Raj Feb 27 at 13:44
    
Did you at least installed java? –  Braiam Feb 27 at 13:48
    
yes yes please tell how to I have installed java (google chrome) –  Jatttt Feb 27 at 13:59

2 Answers 2

If you do have Java installed, you need the icedtea plugin.

sudo apt-get install icedtea-plugin

Restart your browser and Java should be working.

share|improve this answer
4  
icedtea is a NPAPI plugin that Chrome/Chromium no longer supports. –  Redsandro Jul 24 at 23:11

Java have a page that shows you how to do this. Java Instructions

The following is the instructions from that page

Follow these instructions to enable Java in your web browser on Ubuntu Linux. Google Chrome

  1. Become the root user by running the su command and then enter the super-user password. Type: sudo -s
  2. Create a directory called plugins if you do not have it. Type: mkdir -p /opt/google/chrome/plugins
  3. Go to Google chrome plugins directory before you make the symbolic link. Type: cd /opt/google/chrome/plugins
  4. Create a symbolic link. Type: ln -s /usr/local/java/jre1.7.0/lib/amd64/libnpjp2.so
  5. Restart your browser and test Java

Hope this helps

share|improve this answer
    
Nope it doesn't work with version 7 update 65. –  Redsandro Jul 24 at 23:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.