Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently purchased the humble bundle but I am having trouble installing the games and getting them to run.

Some of them are .sh and others are .bin files. On a terminal, I have cd to the location where I downloaded them to and typed chmod +x * so I can apply it to the games that I downloaded. After that i type sudo ./gamefile.sh for the game that is a .sh file.

And when I try to run them I get error saying that a file is not found in the game directory but I see it there and even checked the permissions.

Another game that is a .sh file as well, runs and loads but then it just sends me to straight to the desktop. I don't know if its relevant but I am running the latest Ubuntu version on a Chromebook.

Thanks. So after trying all of the suggestions, I failed to notice an error reported by the terminal while it was installing. `Verifying archive integrity... All good. Uncompressing Mojo Setup.............. Collecting info for this system... Operating system: linux CPU Arch: x86_64 trying mojosetup in bin/linux/x86_64

(mojosetup:12936): IBUS-WARNING **: The owner of /home/user/.config/ibus/bus is not root!`

share|improve this question
    
go into that directory and then post the output of ls -l. – Avinash Raj Feb 27 '14 at 7:38
    
This is the output 'code'user@chrubuntu:~/Downloads$ ls -l total 553208 -rw-r--r-- 1 user user 135103912 Feb 26 23:55 Guacamelee_linux_1393037377.sh.crdownload -rw-r--r-- 1 user user 71118848 Feb 26 23:55 TheSwapper_linux_1393032248.sh.crdownload -rwxr-xr-x 1 user user 360250505 Feb 26 23:18 fez-bin'code – user252836 Feb 27 '14 at 7:56
    
But there is no gamefile.sh file. – Avinash Raj Feb 27 '14 at 8:03
    
Sorry, I should have noted that I used gamefile.sh as an example for a game. – user252836 Feb 27 '14 at 8:04
1  
TheSwapper_linux_1393032248.sh.crdownload it was a partially downloaded file by your chromium-browser. – Avinash Raj Feb 27 '14 at 8:05
up vote 1 down vote accepted

ok then , it is about your OS bit size(32bit or 64bit) you can try : sudo apt-get install ia32-libs and then try installing again.if any problem report us please...

share|improve this answer
    
I just tried it and it said that it is not available anymore but the following packages replace it lib32z1 lib32ncurses5 lib32bz2-1.0 . which one should i try? or should i get all of them? – user252836 Feb 27 '14 at 8:21
    
just open synaptic package manager and search ia32-libs.ifit does not exist try your first section(lib32z1).both are including nearly same files. – RoadRunner Feb 27 '14 at 8:24
    
by the way I guess you have done full access to your downloaded games files.if not, you can also try thoose: -1- cd /your path where game downloaded -2- ls -la (9 to view file priliviges) -3- chown your username your filename -4- chgrp your username your filename -5- chmod +w filename -6- chmod +x yourfilename -7- chmod +r yourfilename try to full acces.because some files needs to extend to hard drive – RoadRunner Feb 27 '14 at 8:30
    
Didn't work, but i tried installing it with gksudo and made some progress because now I get the following error user@chrubuntu:~/Guacamelee$ ./game ./game-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory – user252836 Feb 27 '14 at 8:59
    
I will purchase that games now and try to install to my systems.I will report you if something happens.Let me while. – RoadRunner Feb 27 '14 at 9:12

.sh games:

  1. First of all, download the file that you are going to execute e.g. "name_of_file.sh" and save it in your Desktop

  2. Secondly open the Terminal

  3. Now type cd ~/Downloads (With this command we change the default directory "/" to "/Downloads")

  4. Then type chmod +x name_of_file.sh to make your file executable.

  5. Then type sh ./name_of_file.sh to execute the file.

  6. After that continue as usual.

(Thanks to efthialex @ community.linuxmint)

.bin games:

the .bin files are CD/DVD images it's just a binary file containing installation media just like your normal CD, you will also need .cue files to show the virtual drive emulator where the bin file is located

To create a new .cue file, right-click in the folder where the .bin file is located. Select New, then Text Document. Notepad should open. Enter the following lines into the Notepad document:

    FILE "filename.bin" BINARY
    TRACK 01 MODE1/2352
    INDEX 01 00:00:00

Change “filename” to the name of the .bin file you are loading.

Click File, then Save As… name the file the same as the .bin file, and change the extension from .txt to .cue. Click Save.

Create separate .cue for their respective .bin files (like setup-1.cue,setup-2.cue)

Download daemon tools http://www.disc-tools.com/download/daemon and install it.

then there are 2 ways to open the cue file: 1.You can drag the .cue file onto the icon for the virtual drive in the bottom window of Daemon Tools if you have the program open. The image will mount automatically and the computer will act as if the CD was just inserted.

  1. If you enabled the tray agent then Right-click on the Daemon Tools icon. Select Virtual Devices, then the drive that was created. If there is nothing currently mounted, it will say No Media. Click on Mount Image… Browse for your .cue file and open it. The image will be mounted and the computer will act as if the CD was just inserted.

(Thanks to Allen Hernandez @ yahoo answers)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.