Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a second hard drive that has a partition for /home mounted on the first drive. yesterday, the booting failed because /home cannot be found. I run 'blkid' and see its uuid is gone. but when I run 'fdisk -l' I can see the drive.

I tried to manually mount it but it wouldn't recognize any the filesystem type. and 'dmesg|tail' showed can't find ext3/ext4 and etc.

I also run 'file -Ls /dev/sda1' and it gives '/dev/sda1: data'.

Is there a way that I can access the drive or just copy the data off the drive?

thanks.

share|improve this question
    
What's the output of blkid? –  Avinash Raj Feb 27 at 7:23
    
When you try manually mounting it what is the error message? –  Michael Aquilina Feb 27 at 8:18
    
blkid shows the uuid for the other hard drive. –  Joseph Feb 27 at 20:49
    
I tried to mount it so I can get some important stuff off it. It was mount through fstab and it's not working any more. –  Joseph Feb 27 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.