Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a VERY old kubuntu server that I had to install LXDE on in order to keep it going (before lubuntu was born).

I just upgraded it to 12.04 as I finally had a need for some more modern features. Unfortunately I have no idea how to get auto login to the desktop working again.

I have found suggestions that the following files should be edited

/etc/lxdm/default.conf
/etc/lxdm/lxdm.conf
/etc/xdg/lxdm/lxdm.conf
/etc/lightdm/lightdm.conf

to include something like

[base]
## uncomment and set autologin username to enable autologin
autologin=username

but none of these files exist on my system and I cannot find any promising alternatives.

Any suggestions on what I should try or where I should look next would be greatly appreciated. Thanks

share|improve this question
    
I don't have the following directories at all: /etc/lxdm/ , /etc/lightdm/ , /etc/xdg/lxdm/ or /etc/xdg/lxde/ I do have lxsession and openbox under /etc/xdg/ but these don't contain appropriate .conf files. –  00Kell Mar 13 at 13:08

1 Answer 1

I was trying to set it up for a guest user on lubuntu 14.04. I found an answer that helped me: http://www.htpcbeginner.com/enable-lubuntu-auto-login/

However the file mentioned there: /etc/lightdm/lightdm.conf does not exist in lubuntu 14.04. But there is a file

/etc/lightdm/lightdm.conf.d/20-lubuntu.conf

This is the contents of the file that works for me:

[SeatDefaults] 
user-session=Lubuntu
autologin-user-timeout=0
allow-guest=true
autologin-guest=true

I have just still one nasty pop up error everytime when the system boots up:

No session id for PID $ACHANGINGNUMBERFOREVERYSESSION 

And the screen locks after a couple minutes. (Tried following the procedure in https://help.ubuntu.com/community/CustomizeGuestSession with the guest-prefs user, that user does not get the lockout anymore but the guest user does, even though the profile is soft-linked to the guest skeleton, maybe filerights, I will look into this and come back)

However this may still be usefull for someone, if you find a solution to get rid of that error, please mention it as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.