Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As per title, I cannot boot to Ubuntu 12.04 after upgrading from W8 to W 8.1. I have read several topics on this forum, but I don't seem to be able to solve the problem. I have tried first with Boot-Repair, but it didn't work. I have also tried with the guide at How can I repair grub? (How to get Ubuntu back after installing Windows?) but it did not work either, although I got no error messages (I also tried step no. 7).

I am not sure if I am not identifying the right partition or have some other problem. This is getting annoying and time-wasting. I am quite a noob with Linux, but I do need it for work. If I type:

ls -l /dev/disk/by-label/ 

this is what I get:

lrwxrwxrwx 1 root root 10 Feb 26 19:03 Recovery -> ../../sda5
lrwxrwxrwx 1 root root 10 Feb 26 19:03 System -> ../../sda1
lrwxrwxrwx 1 root root 10 Feb 26 19:03 TI10664600J -> ../../sda4
lrwxrwxrwx 1 root root  9 Feb 26 19:03 Ubuntu\x2012.04.3\x20LTS\x20amd64 -> ../../sr0

(TI10664600J is the Windows partition)

I think I need some help...

Edit: Typing:

sudo parted -l

I get:

Number  Start   End     Size    File system     Name                  Flags
1      1049kB  1075MB  1074MB  ntfs            Basic data partition  hidden, diag
2      1075MB  1347MB  273MB   fat32           Basic data partition  boot
3      1347MB  1482MB  134MB   ntfs            Basic data partition  msftres
4      1482MB  246GB   244GB   ntfs            Basic data partition
6      246GB   301GB   55.0GB  ext4
7      301GB   475GB   174GB   ext4
8      475GB   489GB   14.0GB  linux-swap(v1)
5      489GB   500GB   11.4GB  ntfs            Basic data partition  hidden, diag

I am not sure now which partition I should mount to then install the Grub . As an alternative, should I try to install it on all of them?

OK, second edit: after starting Windows, I can shift-click on restart. Doing so prompts me to a menu when I can choose to boot from a device --> I can choose to boot Ubuntu. The computer restarts and the grub kicks in, with the normal dual boot menu. So, it looks like the grub is still there, it is just not starting when I turn the computer on.

share|improve this question
    
Thanks for editing my message, I was just trying to understand how to change the 'code' part :) –  MadMax Feb 26 at 19:30
    
I ran into exactly the same issue. A method to get grub working is documented here. askubuntu.com/questions/491425/… –  Mahendra Gunawardena Jul 7 at 18:54

3 Answers 3

The Windows upgrade reset some things which you do not want. Under the power settings, turn off "fast boot". That might be all that's needed, but Windows does keep putting itself first in the boot order, so you might have to reorder with some tool like efibootmgr (from Ubuntu) or maybe (not sure about this) bcdedit from Windows.

share|improve this answer

You need to disable secure boot in windows 8.

follow the steps:

1:restart your machine (hold Shift key while doing this)

2: Troubleshoot > Advanced Options> UEFI Firmware Settings :click on restart

3: In the BIOS settings, select boot tab

4: disable secure boot, save and exit.

share|improve this answer

In general, any time you install a new distro or even certain updates to a distro or Windows, the new or updated system will set itself first in the UEFI bootorder. These are usually major updates such as new kernels or the update from Win 8 to 8.1.

The UEFI setup manager (similar to bios settings) should have boot settings that let you select which system should be first in the boot order. You should be able to make Ubuntu first by holding down F2 (your system may use a different key) during startup.

By the way, I've read in the past that Windows always puts itself first in the boot order; but this is not true on my Asus laptop. (But I don't know if this is no longer true in general, just for Ubuntu, or just for Asus firmware.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.