Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am creating a deb package for an opensource project I have started called WideMargin

When I try and install my deb package in 10.10 using the Ubuntu Software Center I get the following text on screen.

Sorry, 'widemargin' is not available for this type of computer (i386).

Despite this message it still installs and works fine.

In my control file I have the following line:

Architecture: all

I assumed this would allow it to work on all architectures.

What am I doing wrong?

As this is an open source project please feel free to poke around in my package source and tell me whats wrong.

I ran the following command as requested:

dpkg-deb --control widemargin_1.0.0_all.deb

And it produced the following results:

Package: widemargin
Version: 1.0.0
Architecture: all
Maintainer: Daniel Hughes <trampster@gmail.com>
Installed-Size: 4744
Depends: mono-runtime (>= 2.6.7), libgtk2.0-cil (>= 2.12.10), libmono-sqlite2.0-cil (>= 2.6.7)
Section: unknown
Priority: extra
Homepage: https://bitbucket.org/trampster/widemargin
Description: Quick and simple bible software.
 Bible software with a focus on speed and usability.
share|improve this question
1  
Software Center is nowadays very picky. Try installing with dpgk. –  Takkat May 14 '11 at 8:44
    
there is no message with dpgk –  trampster May 14 '11 at 8:45
    
@Takkat I am expecting my users to use the software center, So I need to fix the package, not find a work around for installing –  trampster May 14 '11 at 8:47
1  
Can you add the output of dpkg-deb --control your_package.deb to your question? –  Lekensteyn May 14 '11 at 9:01
1  
@lekensteyn that command produces no output.... –  trampster May 14 '11 at 9:16

2 Answers 2

up vote 3 down vote accepted

I solved this problem by...

Rebooting!

And it magically started working. Very strange.

share|improve this answer

My computer is an i386 which is what most computers are. I'm not sure of all the options here, but on my computer the line:

Architecture: all

Should be changed to:

Architecture: i386

share|improve this answer
1  
The program is written in c# and uses mono, it is architecture independent. So it will work on all architectures. As such it does not need to be built for each architecture. –  trampster May 15 '11 at 2:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.