Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First,though this is a duplicate question,but i am asking because the other posts didnt help me,and my case is a little different i guess.

This problem is not recent but since 4-5 ubuntu releases...

When i put my system to sleep,it goes to sleep but when wakes up the screen is totally blank. At this moment the real OS is awake as from a diff system,i can do ssh and even tried to play an mp3 file through mplayer and the music played through the speakers.

So the real issue is that the graphics system is not waking up.

I can debug whats wrong and can compare few things before the sleep and after wakeup,but i dont know what tools would help me to see whats wrong with the graphics hardware not waking up.

So please help me debug this problem.

PS: I am on ATI x700 Mobility Radeon Graphics.

Edit: Logs links: Before log: http://paste.ubuntu.com/607342/

After log: http://paste.ubuntu.com/607346/

share|improve this question
    
Can you post your /var/log/Xorg.0.log, /var/log/pm-suspend.log and /var/log/kern.log files? Does your system respons on toggling Caps Lock? Can you switch to another TTY by pressing Ctrl + Alt + F1? –  Lekensteyn May 14 '11 at 7:18
    
i have attached the logs for before going to sleep and after waking up when the screen is blank. And yes,the Caps lock key is working as it should. –  ashishsony May 14 '11 at 7:57
    
Can you put the logs on paste.ubuntu.com please? I hate mediafire etc for waiting and adverts. Are you able switch to an other TTY using Ctrl + Alt + F1? –  Lekensteyn May 14 '11 at 8:00
    
paste.ubuntu.com DONE.pressing Ctrl + Alt + F1 does nothing... as far as i remember this stopped since a couple of ubuntu releases.. i think ubuntu disabled this hot-key combination since long.. i am on natty. –  ashishsony May 14 '11 at 9:16
    
what happens if you close and (a couple of seconds later) open the lid? If your system then does come back up: I solved this by using the recommended nVidia driver (and not the newest) –  Rinzwind May 14 '11 at 9:21
show 4 more comments

2 Answers

The only suspicious message I found in your logs (kern.log) was:

[drm:drm_mode_getfb] *ERROR* invalid framebuffer id

I'm not sure whether this is

Other things to try:

  • Update your system!
  • Restart GDM over SSH:

    sudo stop gdm
    sudo start gdm
    

    (I had issues with just sudo restart gdm)

  • Reloading the radeon driver:

    sudo rmmod radeon
    sudo modprobe radeon
    
  • If you've SSH access, you can shutdown the machine by running:

    sudo shutdown -h now
    

    If not, you can try pressing Alt + SysRq combined with (in order): R, E, S, I, U, B with small delays (2 secs should be fine) between these. (see wikipedia for explanation)

share|improve this answer
    
once i do sudo stop gdm i cant do anything from the ssh terminal.so not able to do sudo start gdm/ secondly,while doing "sudo rmmod radeon" i get ERROR: Module radeon is in use/ with "sudo rmmod -f radeon" i get ERROR: Removing 'radeon': Resource temporarily unavailable/ and i dont understand what do you mean by this: When shutting down, use sudo shutdown -h now on SSH. If you can't do that, use REISUB/ Thanks for Helping! –  ashishsony May 14 '11 at 11:14
    
It looks like a driver issue then since GDM is blocking. Try filing a bug at launchpad.net. –  Lekensteyn May 14 '11 at 11:56
    
launchpad.net is so complex.. i have no idea how to file a bug..this is a big frustation in relation to ubuntu... such an easy to use OS but such a pain to file bugs.. which equates to.. the humans,for which ubuntu is designed for cant file bugs. Please if you have time do file it for me.Thanks for helping though. –  ashishsony May 14 '11 at 12:44
    
@ashishsony: I find LP very easy to use compared to Bugzilla (used by Mozilla and others). In a default Kubuntu installation, a bookmark is added for reporting bugs, I expect a similar feature for Ubuntu. Before reporting, you've to determine what package the bug should be reporting to. Bugs on xserver-xorg-video-ati. To report a bug, see How do I report a bug? –  Lekensteyn May 14 '11 at 13:06
    
@Lekensteyn: Thanks... i have successfully reported the bug.Ya its easy to report bugs only when u know what package is involved.. as you indicated:xserver-xorg-video-ati.. –  ashishsony May 15 '11 at 5:49
show 2 more comments

I have this problem with NVidia graphics on my laptop and had traced it to the screen being locked while going to sleep. Shall I manually lock the screen before putting the system to sleep, it resumes just fine. Could you please confirm if this helps in your situation?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.