Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the update-manager package and include the following error message: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

sudo apt-get upgrade brings me this.

renamon@Gibson{~}:sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libgl1-mesa-dev linux-headers-generic-lts-raring
  linux-image-generic-lts-raring mesa-common-dev
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

apt-get dist-upgrade -f brings me this

root@Gibson:/home/renamon# apt-get dist-upgrade -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 libgl1-mesa-dri-lts-raring : Depends: libglapi-mesa-lts-raring but it is not going to be installed
 libglapi-mesa-lts-raring:i386 : Conflicts: libglapi-mesa
                                 Conflicts: libglapi-mesa:i386
 libglu1-mesa-dev : Depends: libgl1-mesa-dev or
                             libgl1-mesa-dev-lts-quantal but it is not going to be installed or
                             libgl1-mesa-dev-lts-raring but it is not going to be installed or
                             libgl1-mesa-dev-lts-saucy but it is not going to be installed or
                             libgl1-mesa-dev-lts-trusty but it is not installable or
                             libgl-dev
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
root@Gibson:/home/renamon# 

Dont know much on this end of Linux, still a noob.

share|improve this question
    
This may help you. –  Avinash Raj Feb 26 at 10:16

1 Answer 1

up vote 3 down vote accepted

For the first part about the upgrade, just copy the packages that have been kept back, each line at a time, and append them to a sudo apt-get install statement and press enter.

In your case it will become:

sudo apt-get install libgl1-mesa-dev linux-headers-generic-lts-raring linux-image-generic-lts-raring mesa-common-dev

This will take care of your 'these packages have been kept back error'.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.