Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had a problem with the Dash bar in Ubuntu (11.04) Unity getting "stuck open". It happens when I'm dragging songs to a playlist in Clementine.

In any case, once it's stuck open, I haven't found any way to close it without logging out and logging back in. (I've tried going into about:config and changing the hide condition, but this doesn't help once the dash is stuck open).

So my question is: how to force the dash to close once it's stuck open?

[The issue itself is a bug in unity: see https://bugs.launchpad.net/unity/+bug/769703 ]

share|improve this question

closed as off topic by Marco Ceppi May 14 '11 at 12:06

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

I've been able to press ctrl+alt+F1 to switch to a console. (By default you can choose to use F1-F6 for a console.) Then just log in and run:

unity --replace

That restarts all of unity, including the dash. Press ctrl+alt+F7 to get back to the desktop GUI.

share|improve this answer
1  
It's easier to use Alt+F2 and type compiz --replace, if it works. If not, I usually open a terminal (Ctrl+Alt+T) and type compiz --replace, then do the Alt+F2 thing. (I do so twice to keep Compiz from running in a terminal window.) –  Scott Severance May 14 '11 at 8:05
    
Yeah, Scott's answer works quicker if your dash isn't frozen up. Which in Marco's case sounds like it wouldn't be. For me, dash usually freezes up, meaning that alt+F2 doesn't respond. –  Gus E May 14 '11 at 15:34
    
I haven't be able to get unity --replace to actually unfreeze the Dash. Unity restarts, but the Dash is still stuck open. What seems to work in my case is to force Clementine to close (by kill -9 'ing it). –  emacsomancer May 15 '11 at 17:53
    
Simple command unity -v worked for me. –  motobói Oct 26 '12 at 15:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.