Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I often get stuck at the boot on battery.

I can suspend and hibernate without any trouble (even on battery).

If I plug the energy cable everything goes right most of the time (edited June 13).

Adding "acpi=off" doesn't solve the issue.

Disabling power save from LAN at BIOS doesn't solve this too.

enter image description here

Memory test seems to be ok:

enter image description here

I can even compile a kernel without a problem:

enter image description here

Has someone a tip for this?
(I have the same questions marks in my mind as the image shows if not more :-/ )

obs.: this is an upgraded installation from Natty alpha.
edited I (May 22): I've installed a brand new final 11.04 and got the bug again.

edited II (June 13): I thought it was solved but it is not. After spending eight days off, the same problem happened even with the power cable connected. I had to reboot about 6 times until success.

edited III (June 14): I can boot (even with battery) if I disconnect the cable and take off the battery for a few seconds. This lead me to conclude that maybe something is kept into memory of some hardware. Maybe or maybe not related but I also have touchpad issues (jumps) with this machine.

edited IV (June 25): I opened gconf-editor and went to apps > gnome-power-manager and disabled everything possibly related to suspend or hibernate. No help.
Also I grabbed a Fedora live usb pendrive and got the same problem:

enter image description here

So I think it is a hardware problem related issue.

share|improve this question
1  
Wow. That ain't pretty. Do you have any other working OS's on that machine? –  boehj May 14 '11 at 2:48
1  
looks like a suspend/hibernate issue to me. –  Takkat May 14 '11 at 10:20
1  
I've seen some wifi cards cause these sort of issues - can you pull out/disable in bios to see if this is the cause? –  fossfreedom May 22 '11 at 22:26
1  
... also, various IRQ issues - does booting with noapic or nolapic make any difference? –  fossfreedom May 22 '11 at 22:32
1  
This is happening to me when i'm using for a long time VLC... maybe some problem with hibernate/suspend? –  Jorge Pinho Jun 13 '11 at 14:53

3 Answers 3

Have a look inside log file viewer (press super and type "log file viewer") and see if you can find error messages prior to the bad_area_nosemaphore in your screenshot.

bad_area_nosemaphore: one of the causes for this can be faulty memory. That can also explain why you sometimes have a problem: if that bad memory is not touched everything works like a charm. If it does get touch unexpected results can be expected. In general: irregular behaviour during boot always start thinking memory 1st.

So run memtest from the live cd or from grub if you can boot into it and see if 1 of your memory modules is in bad shape and if so replace it.

share|improve this answer
    
Thank you very much Rinzwind. But (fortunately?) memory test seems to be ok. –  desgua May 16 '11 at 2:24
1  
Try compile linux kernel, it's the best memory test I ever seen. If you get segfault - memory is bad. –  Extender May 16 '11 at 3:06
    
@Extender I will try it. Thank you very much. @Rinzwind: I could not find the errors messages showed in the picture :-/ –  desgua May 16 '11 at 10:38
    
@Rinzwind I couldn't find anything at log file viewer. The errors seams that weren't recorded :-( –  desgua May 16 '11 at 22:32
1  
I'm out of options _O- sorry. –  Rinzwind May 17 '11 at 9:51

If this was from an alpha I would do a clean install, but that's my personal choice.

Having said which, looking at the evidence I would say that the kernel is probably trying to determine settings by probing interrupts or loading a module.

Try turning off the acpi in the grub boot parameters.

share|improve this answer
    
I will try that, thank you very much. I'm curious trying to find the problem, and a little bit afraid of nothing being able to boot if I need. I will search more for a fix before given up and reinstall ;-) –  desgua May 17 '11 at 13:14
    
Well. I've tried both. I've installed a brand new final 11.04 and got the bug again. Then I've added "acpi=off", but unfortunately neither solve the issue. When I plug the energy cable all goes right. :-/ Thank you nevertheless. –  desgua May 22 '11 at 21:59
    
It's been 3 days that the problem didn't happened again, so I think it could be a matter of software bug. –  desgua Jun 1 '11 at 18:01
    
I thought it was solved but it is not. After spending eight days off, the same problem happened even with the power cable connected. I had to reboot about 6 times until success. –  desgua Jun 13 '11 at 14:38
up vote 0 down vote accepted

I found a fix but not an explanation therefore help still needed here ;-)

The Fix
Disconnect the cable and take off the battery for a few seconds.

Conjectures
This fix lead me to conclude that maybe something is kept into memory of some hardware. Maybe or maybe not related but I also have touchpad issues (jumps) with this machine (that isn't solved with the take off of battery procedure).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.