Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed Ubuntu 12.04.4 64 bits, all seemed to be ok, when I started to work on console I noticed:

  • that I couldn't get some accented characters typed in to the console, for example, if I tried to type é I would get a ?
  • That neither a ls or any other unix commands output would display such characters properly.
  • ANSIX3.4-1968 appeared as default character encoding in terminal, so:
    • I changed the character encoding to UTF-8 at Set Character Encoding option in Terminal menu. I can type these special characters properly but can't get other commands to output in a correct way. And I have to change this every time I open a new console.

When I install anything I see this among the outputs and log info:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "en_US:en",
    LC_ALL = (unset),
    LC_TIME = "es_MX.UTF-8",
    LC_MONETARY = "es_MX.UTF-8",
    LC_ADDRESS = "es_MX.UTF-8",
    LC_TELEPHONE = "es_MX.UTF-8",
    LC_NAME = "es_MX.UTF-8",
    LC_MEASUREMENT = "es_MX.UTF-8",
    LC_IDENTIFICATION = "es_MX.UTF-8",
    LC_NUMERIC = "es_MX.UTF-8",
    LC_PAPER = "es_MX.UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory

Also if I do a typo at any command working from console I get:

Sorry, command-not-found has crashed! Please file a bug report at:
https://bugs.launchpad.net/command-not-found/+filebug
Please include the following information with the report:

command-not-found version: 0.2.44

My settings at install were only English language and Spanish Keyboard layout. What could it have happened? And how can I fix it permanently?

share|improve this question
    
Oddly on 14.04.2 (linux-image 3.16.0-41-generic) I have the exact same problem. The context is somewhat different though as $ locale yields: LANG=en_US.UTF-8 LANGUAGE=en_US:en_AU:en_CA:en_GB:en_NZ:en LC_CTYPE="C" LC_NUMERIC="C" LC_TIME="C" LC_COLLATE="C" LC_MONETARY="C" LC_MESSAGES="C" LC_PAPER="C" LC_NAME="C" LC_ADDRESS="C" LC_TELEPHONE="C" LC_MEASUREMENT="C" LC_IDENTIFICATION="C" LC_ALL=C I am sure the key is to change one of those parameters to st more tolerant of accents. Report. –  Cbhihe Jun 30 at 12:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.