Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude E6400 laptop. I've had Ubuntu 10.04 64-bit working for years. I decided to update to 11.04 (via 10.10) and it's fine except Unity won't load. I get the backdrop, the WiFi network notification, and I can see the mouse pointer. Ctrl+Alt+Delete gives me the restart/shutdown/etc. options.

If I select Ubuntu Classic at the login screen, it loads fine. I've tried fiddling with a few ccsm settings but it makes no difference. I've disabled GNOME compatibility, and enabled the Unity plugin. If I type:

unity --reset

from classic mode it loads up Unity, suggesting there's no obvious problem with the drivers. There are some error messages but I lose the ability to move windows around at this point and I don't seem to be able to cut/paste the messages.

I did fiddle with Compiz in the past to get the appearance menu to allow me to select none for animations and have it stick. Perhaps I have to uninstall/reinstall something?

This is very annoying - it seems like I'm very close to having it working but I don't know what to try next. Any suggestions?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I had to do a clean install from a Live-CD to get a working install. As an online upgrade, both metacity and unity were never started.

share|improve this answer
    
I was kind of hoping that getting a different set of icons/menus appearing didn't require a full reinstall. That's more a Windows thing, isn't it? –  Poldie May 14 '11 at 13:41
    
I did a reinstall. It works now. I don't like Unity one little bit but I'll check it out and give it a fair chance, otherwise I'll be installing Debian. –  Poldie May 15 '11 at 12:55
add comment

Press ALT+F2, type

ccsm

and press ENTER

Click to preferences from compiz main window

Select Default settings for unity profile, close the compiz window.

Open a terminal and type this:

sudo apt-get --reinstall install ubuntu-desktop unity
sudo reboot

Login to Ubuntu session

share|improve this answer
1  
Thanks. I tried that, but it's made no difference. I choose 'ubuntu' on the login screen, which used to mean it would try to log on using Unity, but now it just logs on normally; succesfully, but without Unity. I'm going to see if I can find some more settings to experiment with. –  Poldie May 14 '11 at 13:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.