Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to set the nomodeset parameter when booting from grub to make the new kernel 2.6.38 work. The first time I did it I got a message stating that for some kind of limitation I couldn't login with Unity, I suppose it was related to this parameter.

If I boot with the 2.6.35 everything is working perfectly (nomodeset needs not to be set), and Unity is OK. Is it somehow possible to login with Unity even if the nomodeset parameter is set?

Thanks!

share|improve this question
    
Please file a bug for your system indicating you need nomodeset as a parameter. We want to find all systems affected by this on Natty. –  Andy May 16 '11 at 15:28
    
Already filed a bugreport and 2.6.39 is ok. –  Luca May 21 '11 at 16:18
add comment

2 Answers 2

up vote 1 down vote accepted

I assume, in conclusion, that it is not possible to login in Unity when nomodeset parameter is set. If anyone else had any more complete information, please answer and I'll check that as correct answer.

share|improve this answer
add comment

Yes, just set it at boot like you did and it will show you that error and drop you into Classic Desktop. From there install your Graphics Driver and reboot.

Try Problem: Need to fully remove -fglrx and reinstall -ati from scratch

share|improve this answer
    
My graphics driver? I already have my graphics driver installed... I have an ATI and so I ha installed xserver-xorg-video-ati, xserver-xorg-video-radeon etc... Isn't this sufficient? –  Luca May 13 '11 at 23:32
    
Rename xorg.conf and reboot. sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak –  wojox May 13 '11 at 23:36
    
I don't have any xorg.conf there. I only have many xorg.conf.*. Which one? All of them? –  Luca May 13 '11 at 23:44
    
Already gone through that link and did everything. Nothing changed. The proprietary drivers are not installed, just the opensource ATI drivers are. –  Luca May 14 '11 at 16:56
    
@Extender: What do you mean? I can't understand... I do have open drivers... I would like to know if it is possible to run Unity with that parameter set, because my system seems to require it for 2.6.38. –  Luca May 14 '11 at 16:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.