Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In TuxGuitar (http://tuxguitar.herac.com.ar/), I have been using the FluidSynth plug-in to output the MIDI conversion using various soundfonts. This has worked well enough since Ubuntu 10.04. After updating my system from 13.04 to 13.10, the sound now works sometimes and doesn't others.

The failure makes all of the output sound like it's being played through a broken speaker. There is sound, but it's crackling and sort of sounds like a piece of metal being thrashed back and forth (any sense of pitch is lost).

The cause of the failure is unknown. It will be working well, and then less than two seconds later make the terrible noises. I can make no changes, simply press 'play' then 'stop' and then 'play' again and the first time it will work and the second time it will fail.

I have attempted multiple reinstalls of both the software and the FluidSynth plugin, installing from source as well as from Ubuntu's Software Center. Among other fixes, I've tried using the built in Gervill Sequencer (which also failed) and using the ALSA output. Other software seems to be working correctly (MuseScore is running the FluidSynth plug-in with no crashes).

EDIT: After trying the Gervill sound output with the "Real Time Sequencer" Gervill is behaving correctly. This is not a complete solution though, as Gervill sounds terrible and does not allow for any new SoundFonts. The problem may lie with how the FluidSynth Plug-In is behaving; though that does explain the problems below.

Other bugs in TuxGuitar after upgrade is the "History" tab not loading within the file menu and frequent crashes when attempting to open new files.

I have yet to find any workarounds for this problem. Here is an error trace from running the program in the Terminal; but these were present even in 13.04 when the program still ran correctly. Each of these is repeated hundreds of times.

(TuxGuitar:5919): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed
(TuxGuitar:5919): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.38.1/./gobject/gclosure.c:697: unable to remove uninstalled invalidation notifier: 0x7fcd9fb92be0 (0x7fcde4562850)

What upgrades during 13.04->13.10 may have effected the TuxGuitar Dependencies that could cause it to become unstable?

share|improve this question

closed as off-topic by bain, Eric Carvalho, bodhi.zazen, Sneetsher, Radu Rădeanu Jul 8 at 8:52

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eric Carvalho, Sneetsher, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.