Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Ubuntu and I have a problem with the keyboard backlight on my laptop. I was looking for solutions on the web but unfortunately I could not find anything specific.

  • My laptop model is Toshiba Satellite P755-S5269.
  • In the BIOS keyboard backlight is set to ON.

Does anyone have this model laptop and managed to solve this problem?


Eco mode if off, as well as the BIOS setting for the backlight is ON. I just tried Fn+Z but it still doesn't work. I haven't tried the media key for illumination because I don't know where's the media key for illumination? My configuration file /etc/default/grub looks after modification as follows -> http://pastebin.com/wx0rBug1

share|improve this question

1 Answer 1

Try adding the keys:

acpi_osi=linux
acpi_backlight=vendor

to the grub linux line at the "quiet splash" location. If that works, edit them into the /etc/default/grub file on the GRUB_CMDLINE_LINUX_DEFAULT line (when it works after typing it in at the grub prompt): GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_backlight=vendor"


Make sure eco mode if off as well as the BIOS setting for backlight is ON. Try the media key for illumination (above function keys if present) , and also try the key shortcut Fn Z
Hope that helps.

share|improve this answer
    
I added to the file these two lines turned off and turned on my computer but it didn't work. –  user3048580 Feb 26 at 9:11
    
Eco mode if off, as well as the BIOS setting for the backlight is ON. I just tried Fn+Z but it still doesn't work. I haven't tried the media key for illumination because I don't know where's the media key for illumination? My configuration file /etc/default/grub looks after modification as follows -> pastebin.com/wx0rBug1 –  user3048580 Feb 26 at 19:45
    
I fixed a bug in the file grub and still no result: ( –  user3048580 Feb 27 at 19:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.