Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, I've bought a computer, on which I installed a dual boot Windows 7 and Ubuntu 13.10 installation. I have temporary access to a wired connection, but I bought a Asus PCE-N15 wireless network adapter to connect. For Windows 7, I got this adapter to work using the drivers. In Ubuntu 13.10, however, I did not manage to connect it properly.

Following some good leads on askubuntu, I got abit closer, for example

I downloaded and compile the drivers from https://github.com/FreedomBen/rtl8188ce-linux-driver . I followed the instructions in the README.md file coming with this repository.

Before I started altering anything, I have the following output from lsmod | grep ^rtl

rtl8192ce              53550  0 
rtl_pci                26641  1 rtl8192ce
rtlwifi                63229  2 rtl_pci,rtl8192ce
rtl8192c_common        48877  1 rtl8192ce

After following the instructions (i.e. also editing /etc/modules/ and rebooting), I cannot seem to add any off the other modules.

root@bernhard-desktop:/home/bernhard# lsmod | grep ^rtl
rtl8192ce             137725  0 
rtlwifi               110108  1 rtl8192ce
root@bernhard-desktop:/home/bernhard# modprobe rtl_pci
FATAL: Module rtl_pci not found.
root@bernhard-desktop:/home/bernhard# modprobe rtl_8192c_common
FATAL: Module rtl_8192c_common not found.

When rebooting, after a little while, I get a notification that tells me that I am connect to my Wifi-network. However, when I try to open a web-page or make an ssh-connection, I do not get any information transfered, which is not a problem for my wired connection.

Proof of the above statements is as follows

root@desktop# nmcli d
DEVICE     TYPE              STATE        
wlan0      802-11-wireless   connected    
eth0       802-3-ethernet    unavailable

root@desktop# ping -c2 4.2.2.2
PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.

--- 4.2.2.2 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1007ms

My question is the following: What am I overlooking, or doing wrong, and how can I fix this issue and connect to the internet by wifi, using my Asus adapter?

share|improve this question
    
Are you still working on getting this working? –  Freedom_Ben May 4 at 2:05
    
@Freedom_Ben No, after connecting my wired connection, I gave up. Funny story is that I needed to install additional drivers for my Windows 7 dual boot, but Ubuntu recognized it directly :) –  Bernhard May 4 at 6:36

1 Answer 1

First, the driver you built from github does not depend nor require rtl_pci nor rtl_8192c_common. The module mac80211 is required. Is it loaded?

lsmod | grep 80211

Please be certain that any ethernet cable is detached as you try to connect. Network Manager will prefer ethernet over wireless and is intended to disallow wireless if ethernet is available.

Second, be sure your router is set to WPA2-AES only, no TKIP nor mixed mode WPA/WPA2. Experiment with and without N speeds enabled.

Finally, let's try a driver parameter:

sudo modprobe -r rtl8192ce
sudo modprobe rtl8192ce swenc=1

If it helps, we'll write a quick file to make it persistent.

Look for any clues as to why it isn't working with:

cat /var/log/syslog | grep -e rtl -e etwork | tail -n 25

As the file is quite sizable, post it here and give us the link in your reply: http://paste.ubuntu.com

share|improve this answer
    
I rebooted without ethernet attached, mac80211 is loaded (as well as cfg80211 if that is relevant). Will now check your other hints –  Bernhard Feb 25 at 14:24
    
From the specifics of the router, it says it supports WMM, WPA-PSK, WPA2-PSK,. In the Wi-Fi security settings, "WPA & WPA2 Personal" is selected (other options are WEP, LEAP, Dynamic WEP). I am not sure how to process or enable N speeds. –  Bernhard Feb 25 at 14:31
    
The driver parameter swenc=1 does not seem to make a difference. –  Bernhard Feb 25 at 14:33
    
I believe you want WPA2-PSK. Perhaps your router doesn't do N speeds at all. Please see my edit. –  chili555 Feb 25 at 15:15
    
For the pastebin: paste.ubuntu.com/6996799 –  Bernhard Feb 25 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.