Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two monitors (24" as main and a 19" to the left).

Each time I want to swap to a different application or launch a new one, the launcher seems a little problematic to come up. Even though moving my mouse across the top Ubuntu logo gets it up, it still seems quite spasmodic.

Anybody else found a problem and is there a solution?

share|improve this question
add comment

2 Answers 2

Create a Mouse Void

This is quite a long answer that I felt is better kept separate from my other one.

So that you understand where this solution came from, my monitor layout is as follows:

desktop

The two black area 1280x88 are off the screen but my mouse can still enter this due to an X bug. The workaround is a small program that prevents the mouse entering this void called XCreateMouseVoid.

Home Button Mouse Stopper

You can also use XCreateMouseVoid to create a small box that the mouse will stop against when pushed into the top left corner of the primary screen. This is what I have shown in green area of this image:

mousevoid

Installing

  1. Download XCreateMouseVoid and extract the files to your home folder
  2. Open the folder in Terminal and run this command:

    cd ~/XCreateMouseVoid && make
    
  3. Test the program with values:

    ~/XCreateMouseVoid/XCreateMouseVoid 0 0 1280 88
    
  4. Add to Startup Applications so its always runs upon bootup.

Calculate Values

The values required for XCreateMouseVoid are: x, y , w, h

  • x & y refer to the start co-ordinates of the rectangle. These co-ordinates are based upon the whole desktop area and not individual monitors.
  • w & h refer to the width and height of the rectangle

For my setup to stop the mouse entering the top and bottom black 1280 x 88 areas along with stopping it travel past the Home Button, I run two instances of the program with these values:

XCreateMouseVoid 0 0 1280 88
XCreateMouseVoid 0 1112 1280 88

Small Rectangle

If you have a different setup you can create the small rectangle as I mentioned earlier. The rectangle measures 60 x 25, which is the minimum width needed to properly stop the mouse.

The only value you need to change is x which is calculated by subtracting 60 from your secondary monitor's width. e.g. 1280 x 1024 monitor I subtract 60 from 1280 to get the value 1220 for XCreateMouseVoid:

XCreateMouseVoid 1220 0 60 25

Trapped Mouse Cursor

Occasionally the mouse cursor can jump into the created mouse void and become trapped. The solution is to press either the Super or Menu key so that a menu opens and frees the mouse cursor.

share|improve this answer
    
It works, but the mouse cursor may get trapped by XCreateMouseVoid. The cursor won't get out from the void without killing the program. This seems to happen more likely if the cursor moves fast to the invisible area. –  taneli Sep 13 '11 at 8:16
    
I only really get that happening on rare occasions when selecting desktop icons however I found that opening Dash with the super key seems to free the cursor. Let me know if that works for you and I can add that to my answer. –  Cas Sep 13 '11 at 13:31
    
Super does not do anything on my lucid setup, however, pressing the menu key brings forth the context menu and frees the cursor. (I have a broken mouse at work, the cursor likes to jump large distances and thus makes the disappearance happen quite often. Kids do the same, actually, even with non-broken mice ;) –  taneli Sep 14 '11 at 8:05
add comment

I have the same setup and it is quite annoying. The reason it doesn't work well with secondary monitor to the left is there is no barrier to stop the cursor from moving further to the left off from the home button which normally occurs in a single monitor scenario.

Mouse Precision

You need to be very precise and put the mouse cursor only in the top left corner pixels of the main screen.


Shortcuts can be used as an alternative:

  • Hold down the Super key and use either mouse or keypad
  • Press Alt+F1 and use arrow keys

Disable the Launcher from hiding:

  1. Install Compiz Config Settings Manager Install compizconfig-settings-manager from the Ubuntu Software Center

  2. Open Compiz Config Settings Manager from Dash

  3. Find Unity plugin and change Hide Launcher to Never


Open with left edge of screen:

You can actually open the Launcher by moving the mouse to the far left of the secondary monitor if you have enabled Pushes left edge of screen in Launchers and Menus. It's not intutive nor ergonomic but it works.


share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.