Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the software center, there are so many softwares with needs KDE or this is GTK comaptible. Can this software work in Xubuntu xcfe?

share|improve this question
1  
If it needs KDE, it will download and install KDE before trying to install itself. GTK is more robust, but the principles are same. The GTK libraries will be downloaded and installed. After this you will get access to that application, and it will mimic your standard desktop elements. Also, if you install KDE you will be able to login into KDE, but GTK has no default desktop so you can use it's applications in both XFCE and KDE. –  Danatela Feb 25 at 7:16

1 Answer 1

Yes, all software will work between desktop environments with little issues.

But...

Lets say that you are using Xfce (GKT2) and you want to install software that was built for GNOME Shell (GTK3), all the libraries that are necessary to run that application will be downloaded (and that might be "a lot"), the same goes for other desktop environments.

It will not harm your system, but it might be too much compared with the size of the application that you want to use.

An example: Let's say I want to install Kate (the beautiful text editor from KDE, less than 1MB for the application itself) in my clean Ubuntu desktop. It will pull 65MB of packages and in the end will occupy more than 180MB in total because it pulls a lot of dependencies:

consolekit docbook-xml docbook-xsl kate-data katepart kde-runtime kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools kubuntu-debug-installer libattica0.4 libdlrestrictions1 libepub0 libgpgme++2 libkactivities-bin libkactivities-models1 libkactivities6 libkateinterfaces4 libkatepartinterfaces4 libkcmutils4  ibkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkubuntu0 libkxmlrpcclient4 libnepomuk4 libnepomukcleaner4 libnepomukcore4abi1 libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libpam-ck-connector libphonon4 libplasma3 libpolkit-qt-1-1 libpoppler-qt4-4 libqapt2 libqapt2-runtime libqca2 libqjson0 libqmobipocket1 libqt4-qt3support libsolid4 libsoprano4 libstreamanalyzer0 libstreams0 libthreadweaver4 libvirtodbc0 libzip2 nepomuk-core-data nepomuk-core-runtime ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-gstreamer phonon-backend-gstreamer-common plasma-scriptengine-javascript qapt-batch sgml-data shared-desktop-ontologies soprano-daemon ttf-dejavu-core virtuoso-minimal virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common

I mean, what is 180MB now a days? Not much, but compared with the 1MB that the application actually is... Does not make much sense and will drive most users to look for alternatives elsewhere.

share|improve this answer
    
If I download one program with say, KDE, and consequently the big download, and then I download multiple KDE based programs after that, am I getting the big downloads with each or are they sharing the KDE? I like this KDiff3. It says it's KDE. It also says a "stripped down" version (kdiff3-qt) is available but I couldn't find it anywhere. And is all the xfce/Gkt2 software second-rate (compared to the KDE/Gnome/QT software)? And all the download info. on Ubuntu Software Ctr (eg.For Kate it says 3.2mb installed.) that doesn't apply to me (using xfce)? Any way to filter search n UFC 4 only XFCE? –  user250093 Feb 25 at 9:20
    
The same libs will be used after installation, so it will not be multiples of the library. Only one installation by package. –  Bruno Pereira Feb 25 at 9:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.