Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 13.10 and the fans are quite loud. I followed the instructions on this forum link and configured lm-sensors then attempted to configure fancontrol. I ran lm-sensors as sudo, it found some things and I loaded the modules it recommended into the kernel. However when I ran pwmconfig it said "There are no pwm-capable sensor modules installed". When I run the sensors command I get the following output. I'm not sure if any of these temps seem high. Anyway, not sure what else to try.

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +40.0°C  (high = +79.0°C, crit = +99.0°C) 
Core 1:       +40.0°C  (high = +79.0°C, crit = +99.0°C)
Core 2:       +43.0°C  (high = +79.0°C, crit = +99.0°C)
Core 3:       +37.0°C  (high = +79.0°C, crit = +99.0°C)

atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage:       +0.93 V  (min =  +0.80 V, max =  +1.60 V)
 +3.3 Voltage:       +3.30 V  (min =  +2.97 V, max =  +3.63 V)
 +5 Voltage:         +5.07 V  (min =  +4.50 V, max =  +5.50 V)
 +12 Voltage:       +12.14 V  (min = +10.20 V, max = +13.80 V)
CPU FAN Speed:      1041 RPM  (min =  600 RPM, max = 7200 RPM)
CHASSIS1 FAN Speed: 1110 RPM  (min =  600 RPM, max = 7200 RPM)
CHASSIS2 FAN Speed: 1638 RPM  (min =  600 RPM, max = 7200 RPM)
CHASSIS3 FAN Speed:    0 RPM  (min =  600 RPM, max = 7200 RPM)
POWER FAN Speed:    1461 RPM  (min =    0 RPM, max = 7200 RPM)
CPU Temperature:     +38.5°C  (high = +60.0°C, crit = +75.0°C)
MB Temperature:      +50.0°C  (high = +45.0°C, crit = +75.0°C)

radeon-pci-0200
Adapter: PCI adapter
temp1:        +64.5°C  
share|improve this question
    
What is your hardware? Is this a laptop? There are some brand-specific tools (especially for Dell and Lenovo laptops). –  terdon Feb 25 at 10:56
    
This is a desktop pc using an asus p6T deluxe motherboard. –  LC Dupree Feb 26 at 8:07

1 Answer 1

I don't think you need to control fan speed, actually fan should not make much sound even at high speeds.

If you look at the output of sensors command for my dual-core computer and compare it with yours, you'll find that the fan speed your computer is using is keeping your processors cool, which is important.In my case the processor temp are high but fan speed is low.

Adapter: ISA adapter
Core 0:       +74.0°C  (high = +76.0°C, crit = +100.0°C)
Core 1:       +67.0°C  (high = +76.0°C, crit = +100.0°C)

w83627dhg-isa-0a10
Adapter: ISA adapter
Vcore:        +1.10 V  (min =  +0.00 V, max =  +1.74 V)
in1:          +1.26 V  (min =  +0.05 V, max =  +0.23 V)  ALARM
AVCC:         +3.36 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:        +3.38 V  (min =  +2.98 V, max =  +3.63 V)
in4:          +1.26 V  (min =  +0.02 V, max =  +0.36 V)  ALARM
in5:          +0.78 V  (min =  +1.16 V, max =  +1.86 V)  ALARM
in6:          +0.88 V  (min =  +0.28 V, max =  +0.02 V)  ALARM
3VSB:         +3.39 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:         +3.31 V  (min =  +2.70 V, max =  +3.30 V)  ALARM
fan1:           0 RPM  (min =  405 RPM, div = 128)  ALARM
fan2:        1110 RPM  (min = 6490 RPM, div = 8)  ALARM
fan3:           0 RPM  (min = 1054 RPM, div = 128)  ALARM
fan4:           0 RPM  (min = 10546 RPM, div = 128)  ALARM
fan5:           0 RPM  (min = 10546 RPM, div = 128)  ALARM
temp1:        +38.0°C  (high = +64.0°C, hyst = -43.0°C)  sensor = thermistor
temp2:        +58.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = diode
temp3:        +42.5°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
cpu0_vid:    +0.000 V
intrusion0:  ALARM

aditya@aditya-desktop:~$ 

I'll suggest you to check if the hardware installation of fans is correct(either yourself or from some expert). The sound should vanish by little bit tweaking.If it doesn't work then you may consider decreasing the fan speed by using fancontrol

WARNING
Please be careful when using the fan control features of your mainboard, in addition to the risk of burning your CPU, at higher temperatures there will be a higher wearout of your other hardware components, too. So if you plan to use these components in 50 years, maybe you shouldn't use fancontrol at all. Also please keep in mind most fans aren't designed to be powered by a PWMed voltage. In practice it doesn't seem to be a major issue, the fans will get slightly warmer, just be sure to have a temperature alarm and/or shutdown call, in case some fan fails, because you probably won't hear it anymore ;)

How to use Fancontrol

  • First install fancontrol

    sudo apt-get install fancontrol
    
  • Use pwmconfig, an script to manage fancontrol

    pwmconfig
    

    Now follow the instructions to configure your fan speed.

share|improve this answer
    
Per the link in my original post, I already followed all of these steps. pwmconfig was unable to locate any fans to control. The PC is loud and it is not because of incorrect hardware installation. This PC had Win 7/8 on it and was quiet. As soon as I installed Ubuntu this problem started. –  LC Dupree Feb 26 at 8:08
    
You can set the fan speed also in BIOS menu –  Registered User Feb 26 at 8:22
    
There were no settings there. There's something more going on here isn't there? Linux should be controlling the speed better just like Windows was able to. The machine was much quieter while running Windows. I also have a Radeon 6850 card installed. Could it be a GPU fan? Is there some special driver I should be using? –  LC Dupree Feb 26 at 15:31
    
Maybe just some unwanted material in the fan? Have you tried keeping the side open and booting Ubuntu? –  Registered User Feb 27 at 6:41
    
I just tried again with Windows. As soon as I boot into Windows it is quiet, Ubuntu loud. –  LC Dupree Feb 27 at 7:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.