Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the 3D-Card in the subject. It is ATI-based. I know proprietary driver support for Linux has been dropped a while ago, so I have been struggling for years now, with no success... my high-performance 3D card works as a standard VGA only.

That is why I currently run with Unity-2D.

Even trying the xorg-edgers ppa is not make it work.

Can anyone help me?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I successfully managed to make my X1550 work perfectly using the 300g Gallium driver, it involved installing from Xrog-edgers PPA, but I did all that in Ubuntu 10.10. Now, the 300g drivers come by default with Ubuntu 11.04, so that's strange!

First let's see what's being used, open a terminal and type:

sudo apt-get install mesa-utils

Then, run: glxinfo | grep -i opengl

Normally you should get:

OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RVXXX
OpenGL version string: 2.1 Mesa 7.11-devel
OpenGL shading language version string: 1.20
OpenGL extensions:

Now let's make sure the drivers are in place, type these in the terminal:

sudo apt-get install xserver-xorg-video-ati xserver-xorg-video-radeon libgl1-mesa-dri 
share|improve this answer
    
That is what I get: `OpenGL vendor string: Mesa Project OpenGL renderer string: Software Rasterizer OpenGL version string: 2.1 Mesa 7.10.2 OpenGL shading language version string: 1.20 OpenGL extensions:' –  igi May 13 '11 at 21:43
    
Your driver isn't installed/configured. I'll update the answer. –  Reda Lazri May 14 '11 at 8:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.