Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Okay so I'm not exactly sure how it happened, but recently Ubuntu has been trying to mount an external hard drive that I usually have plugged in during boot. A message comes up during boot asking me to either wait, or press S to skip if the drive isn't plugged in when I start up my laptop.

My question is, how do I disable this drive from mounting at startup so I don't have to prompt Ubuntu to skip it at boot? I've looked up a couple other solutions to this, but all of them only seem to completely disable automounting, which would require me to manually mount the device when it's plugged in, which is not what I want. I just want to disable it from mounting at startup.

share|improve this question

marked as duplicate by Eliah Kagan, AgentCool, Jorge Castro, Eric Carvalho, Stephen Myall Jul 31 '13 at 10:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Are you sure the drive partitions are not in /etc/fstab? –  enzotib May 13 '11 at 19:00
    
It's located there. I have this: /dev/sdb1 /media/My\040Book ntfs I assume I can just remove that line, but considering it's a read only file, it'd have to be done through the terminal, right? –  Chris Kerrigan May 13 '11 at 19:12

3 Answers 3

up vote 4 down vote accepted

If there is a line in /etc/fstab related to that drive, remove it.

The file is read only for all users other that root.

To edit it use the command gksu gedit /etc/fstab, but make a copy of the file before editing, and do not touch nothing other than removing that line.

share|improve this answer
1  
Thanks! Worked like a charm. –  Chris Kerrigan May 13 '11 at 19:32

It is not possible to prevent Ubuntu 11.10 from automounting media when it is plugged in or on booting. Neither of the above solutions work. Simply look in /media for all the automounted devices after trying the above solutions.

share|improve this answer

To disable USB automount in Ubuntu 11.10 (with Gnome 3), launch dconf-editor (package dconf-tools) and uncheck the following entries:

  • org.gnome.desktop.media-handling automount
  • org.gnome.desktop.media-handling automount-open
share|improve this answer
    
If you have a particular drive you do not want to mount which was there when you installed the system and which your system is assuming is permanently connected, than editing /etc/fstab as the other answer suggests, is likely to work. If you want to have GNOME 3 stop automounting drives (like USB drives), then this is the correct approach. –  Benjamin Mako Hill Feb 12 '12 at 18:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.