Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed mariadb 5.5 on my ubuntu laptop like described here:

sudo add-apt-repository "deb http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu $(lsb_release -c -s) main"

and it works fine so far, only there is something odd with aptitude: when I enter

sudo su
LANG=C 
aptitude install

I get these warnings:

The following NEW packages will be installed:
  linux-headers-3.11.0-12 linux-headers-3.11.0-12-generic mysql-client-core-5.5{b} mysql-server-core-5.5{b} 
0 packages upgraded, 4 newly installed, 0 to remove and 2 not upgraded.
Need to get 13.7 MB/21.4 MB of archives. After unpacking 100 MB will be used.
The following packages have unmet dependencies:
 mariadb-server-core-5.5 : Conflicts: mysql-server-core-5.5 but 5.5.35-0ubuntu0.13.10.2 is to be installed.
 mysql-client-core-5.5 : Breaks: mysql-client-core-5.1 which is a virtual package.
 mysql-server-core-5.5 : Breaks: mysql-server-core-5.1 which is a virtual package.
 mariadb-client-core-5.5 : Conflicts: mysql-client-core-5.5 but 5.5.35-0ubuntu0.13.10.2 is to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     mysql-client-core-5.5 [Not Installed]              
2)     mysql-server-core-5.5 [Not Installed]              

Accept this solution? [Y/n/q/?] 

I am confused and press q for quit!

This warning started after some days of usage of my PC using aptitude to keep it updated.

aptitude uses the mariadb repository now. this is my /etc/apt/sources.list:

#begin sources.list
deb http://de.archive.ubuntu.com/ubuntu/ saucy main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy main restricted

...

deb http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu saucy main
# deb-src http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu saucy main

#end sources.list

Why does it want to install an older kernel and do such things?

I am already on

uname -a
Linux myserver 3.11.0-17-generic #31-Ubuntu SMP Mon Feb 3 21:53:31 UTC 2014 i686 i686 i686 GNU/Linux
share|improve this question

1 Answer 1

up vote 1 down vote accepted

it's ppas/sources conflicts... I had this multiple times, the thing is you have added a source (ppa) to your system where you withdraw/fetch updates that has packages of the same one as already one in the system and it's trusted (official). For example happened to me linux-headers 3.x.x.9 installed but linux-headers 3.x.x.8 is to be installed, because source you added has newer kernel recommended for your system than your official source. So that's why it happens and the solution is to remove or disable conflicting ppa in /etc/apt/sources.list and you'll get pass through it in no time :-)

How to find conflicting ppa you need to list its packages to see what packages it contains, I use y-ppa-manager by webupd8 for this things, you can do it your own way.

sudo add-apt-repository ppa:webupd8team/y-ppa-manager
sudo apt-get update
sudo apt-get install y-ppa-manager

The other solution happened to be solved to avoid the conflict is to remove (untick) the main ubuntu repo in /etc/apt/sources.list for example us.ubuntu.archive saucy main restricted (or whatever distributive you have) then do aptitude update and aptitude install then move (tick) the main repo back in and disable the software repository in the sources.list repository.

Also others who be interested you may follow this thread

share|improve this answer
    
let us continue this discussion in chat –  rubo77 Feb 25 at 0:20
1  
we solved it in the chat: conclusion: remove the main ubuntu repo saucy main restricted; then aptitude update and aptitude install; then move the main repo back in. thanks a lot! –  rubo77 Feb 25 at 1:07
    
anytime 24/7 :D –  JohnnyEnglish Feb 25 at 1:09
    
Do you want to add a second answer with the conclusion of our chat? With a description how to solve it (for others reading this post). Then I would mark that answer as the accepted one –  rubo77 Feb 25 at 10:52
    
yeah I did :-) it was a bit late yesterday and I was tired so I went to sleep :D –  JohnnyEnglish Feb 25 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.