Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already install video4linux control panel and I already adjust the settings but the adjusted settings don't work for skype. The video was still green.

How can I fix this?

I'm using Ubuntu 12.04 LTS on Lenovo s10-3.

share|improve this question
    
Is it working fine for other application like cheese? –  G_P Feb 24 at 6:42
    
@guruprasad YES, it works fine with cheese –  user251687 Feb 24 at 6:56

2 Answers 2

Try this:

  1. Right click on skype icon
  2. Click options
  3. Video devices
  4. Make sure everything's ok, an enable/disable auto-exposure(change it)
  5. Close the window
  6. Restart the computer

Let me know if it works.

share|improve this answer

I think you should also try GUVCVIEW webcam software. Code:

sudo apt-get install guvcview

It is a lightweight and handy webcam tool far better than cheese in my opinion, and you can adjust controls more easily in Guvcview. If you like it, and if it works for Skype video settings too, I suggest you get rid of Cheese package permanently.

With guvcview you can preserve the AUTOGAIN function (for a decent image), and at the same time you can disable LIGHT FREQUENCY FILTER so your webcam won't freeze when you're in a video conference. If you want to manually adjust image controls then you must uncheck the AUTOGAIN box first.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.