Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a new install of ubuntu.

Upon first installing the nvidia drivers are not active and I get the correct screen resolution. 1680x1050

Then I install the nvidia drivers and the best resolution I can get is 1280x1024.

In searching around there is a lot of information related to this and similar issues. I have tried tips with xrandr, manually installing the drivers, etc, etc. Finding the right information is proving troublesome however.

I know that the graphics card can out put the correct resolution because it does until the nvidia drivers are activated. So does anyone here know the solution? (Why does this have to be so hard?)

This is not a new whiz bang system, but one I put together with spare parts.

Graphics: NV37GL Quadro PCI-E Series

Monitor: ViewSonic VX2025WM -- This monitor worked correctly on my other ubuntu system with the nvidia drivers, but was connected with VGA instead of digital.

--------------xorg.conf------------after--- 1. Install the restricted drivers System ---> Hardware Drivers-------2. Select the recommended drivers, install and reboot. ------

(# nvidia-xconfig: X configuration file generated by nvidia-xconfig

(# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Sun Nov  8 21:50:38 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

So, any suggestions on this? At this point I'm assuming that the issue has to do with a good xorg.conf file and possibly EDID. A clear set of docs on this issue is hard to find. In searching the forums and other web sites I've found LOTS of others with similar issues, but it's all so scattered that it's hard to tell which ones are not dead ends. Given that many posts are dated as far back as 2006 and earlier, and that nvidia cards are so ubiquitous, it's hard to understand why there isn't an easier solution.

share|improve this question
    
Which drivers did you install, and how? –  ændrük Sep 16 '10 at 21:19
    
Also please add the contents of your /etc/X11/xorg.conf file. –  Jorge Castro Sep 16 '10 at 21:23
    
@aendruk - Installed the nvidia-current on the last attempt. Before that the default -173 rec'd by ubuntu. –  wdypdx22 Sep 16 '10 at 21:29
    
@Jorge - added the xorg.conf file above –  wdypdx22 Sep 17 '10 at 1:51
    
@ændrük - I installed the restricted drivers through: 1. System ---> Hardware Drivers-------2. Select the recommended driver, install and reboot. –  wdypdx22 Sep 17 '10 at 20:03
add comment

marked as duplicate by Luis Alvarado Apr 20 '13 at 1:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

up vote 1 down vote accepted

Do you have "NVIDIA X Server Settings" in your System -> Administration menu? For some reason the nvidia driver does not like to work with the normal X tools sometimes.

Also, try just deleting /etc/X11/xorg.conf and restarting X (sometimes this can be difficult, so it might be easier just to reboot the machine.) When you delete the file Ubuntu or Xorg will detect that it is missing and attempt to rebuild it, guessing at sane settings. If the settings are not satisfactory then you can change them if necessary- but starting over with a "clean" auto-generated xorg.conf is a good way to make sure leftover parts of the configuration aren't tripping you up.

PLEASE NOTE that this worked for me in 9.10 but I have not tested it in 10.04. If anyone knows a reason why this will not work or will break things, please speak up!

share|improve this answer
    
Yes the nvidia x server settings are there. The desired resolution is not listed. –  wdypdx22 Sep 17 '10 at 1:46
    
When your graphics card is displaying at the correct resolution under the nv driver, what is the color depth? It could be that the default depth is 16 in the nv driver and 24 with the nvidia driver, and your card can't cope with the higher resolution at the higher depth. I don't find it at all likely, but it is something to check. –  koanhead Sep 20 '10 at 20:33
    
You can try nvidia-xconfig ---mode=1680x1050 to add the mode to your configuration. You might need sudo for this. See 'man nvidia-xconfig' for more details. That command has a LOT of options... –  koanhead Sep 20 '10 at 20:43
add comment

I was in exactly the same situation as the original poster: original UBUNTU 10.04 installation had 1680x1050 resolution; installing the proprietary driver reduced maximum to 1280x1024.

I installed the proprietary driver because I noticed that with the original driver the display was obviously "painting" the display (from top to bottom) on changes instead of "instantaneously" updating the screen image.

Adding the "magic incantation" of

           Option"ModeValidation" "NoMaxPClkCheck"

in the Device section and PRESTO all the missing resolutions re-appeared (in the /usr/bin/nvidia-settings configuration program).

source: found on http://fedoraforum.org/forum/printthread.php?t=185230&pp=15&page=3

share|improve this answer
add comment

A solution for Nvidia chipset : NVIDIA Graphics - resolution problems with new 12.04 LTS installation

xorg.conf:

Section "Monitor"
    Identifier  "Monitor0"
    VendorName  "Sanyo"
    ModelName   "LCD-32E3"
    HorizSync   30.0 - 50.0
    VertRefresh 50.0 - 60.0
EndSection

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
    Option  "UseDisplayDevice" "DFP"
    Subsection  "Display"
       Modes    "1360x768" "1280x720" "720x480"
    EndSubSection
EndSection

Section "Module"
    Load    "glx"
EndSection

Section "Device"
    Identifier  "Default Device"
    Driver  "nvidia"
    Option  "NoLogo"    "True"
EndSection
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.