Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Xubuntu desktop environment but didn't like it. I found a thread which listed a large command to uninstall everything. Now when my machine boots, I get a black screen and no possibility of logging in.

How do I fix this? I don't particularly want to have to reinstall Ubuntu.

The command I entered to uninstall it was this:

sudo apt-get remove abiword abiword-common abiword-plugin-grammar abiword-plugin-mathview alacarte bison blueman brltty-x11 catfish espeak exo-utils flex fonts-droid fonts-lyx gigolo gmusicbrowser gnome-system-tools gnome-time-admin gstreamer0.10-gnomevfs gthumb gthumb-data gtk2-engines-pixbuf indicator-application-gtk2 indicator-sound-gtk2 leafpad libabiword-3.0 libbison-dev libdigest-crc-perl libexo-1-0 libexo-common libexo-helpers libfl-dev libgarcon-1-0 libgarcon-common libgdome2-0 libgdome2-cpp-smart0c2a libglade2-0 libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgsf-1-114 libgsf-1-common libgstreamer-perl libgtk2-notify-perl libgtk2-trayicon-perl libgtkmathview0c2a libgtkspell0 libido-0.1-0 libindicate-gtk3 libintl-perl libjpeg-progs libjpeg-turbo-progs libkeybinder0 liblink-grammar4 libloudmouth1-0 libnet-dbus-perl liboobs-1-5 libotr2 libots0 librarian0 libsexy2 libtagc0 libthunarx-2-0 libtidy-0.99-0 libtie-ixhash-perl libtumbler-1-0 libunique-1.0-0 libvte-common libvte9 libwv-1.2-4 libxfce4ui-1-0 libxfce4ui-utils libxfce4util-bin libxfce4util-common libxfce4util6 libxfcegui4-4 libxfconf-0-2 libxml-parser-perl libxml-twig-perl libxml-xpath-perl lightdm-gtk-greeter link-grammar-dictionaries-en m4 orage parole pastebinit pavucontrol pidgin pidgin-data pidgin-libnotify pidgin-microblog pidgin-otr plymouth-theme-xubuntu-logo plymouth-theme-xubuntu-text python-configobj rarian-compat ristretto screensaver-default-images scrollkeeper shimmer-themes system-tools-backends tcl8.5 thunar thunar-archive-plugin thunar-data thunar-media-tags-plugin thunar-volman tumbler tumbler-common xbrlapi xchat xchat-common xfburn xfce-keyboard-shortcuts xfce4-appfinder xfce4-cpugraph-plugin xfce4-dict xfce4-indicator-plugin xfce4-mailwatch-plugin xfce4-netload-plugin xfce4-notes xfce4-notes-plugin xfce4-notifyd xfce4-panel xfce4-places-plugin xfce4-power-manager xfce4-power-manager-data xfce4-quicklauncher-plugin xfce4-screenshooter xfce4-session xfce4-settings xfce4-systemload-plugin xfce4-taskmanager xfce4-terminal xfce4-verve-plugin xfce4-volumed xfce4-weather-plugin xfce4-xkb-plugin xfconf xfdesktop4 xfdesktop4-data xfwm4 xscreensaver xscreensaver-data xscreensaver-gl xubuntu-artwork xubuntu-default-settings xubuntu-desktop xubuntu-docs xubuntu-icon-theme xubuntu-wallpapers && sudo apt-get install ubuntu-desktop
share|improve this question
    
Press ctrl + alt + F1, then type in your usual username and password. Then run sudo apt-get --reinstall install ubuntu-desktop. –  henry Feb 23 at 19:32
    
did you just install xubuntu and didn't like it? if you have no data to lose then do a fresh installation of the dustro you like –  Fischer Feb 23 at 19:48
    
Sorry, I should've specified. I installed the xubuntu desktop environment. I'll update the post. –  user1147964 Feb 23 at 19:52

2 Answers 2

  1. After getting blank screen type: ctrl +alt +f1.
  2. Now edit your /etc/X11/default-display-manager file using by typing: sudo vi /etc/X11/default-display-manager. It will open file in vi editor.
  3. Replace everything (if it contains something) with /usr/sbin/lightdm
  4. Press escape button and type :wq! to save change and exit.
  5. Now restart your computer.

It should solve your problem.

share|improve this answer
    
The file is completely empty apart from the first line which says: /usr/sbin/lightdm What else could the problem be? –  user1147964 Feb 23 at 20:01
    
try sudo service lightdm restart –  g_p Feb 23 at 20:11
    
I'm afraid that also fails :( Same error: Job failed to start –  user1147964 Feb 23 at 20:11
    
press ctrl+alt+f1 and log in. After login type startx and see what happens. –  g_p Feb 23 at 20:15
    
That definitely works. I get the unity desktop, but with no icons in the top right and no fancy effects –  user1147964 Feb 23 at 20:17

I'm assuming you had installed "Xubuntu-desktop" on Ubuntu? In which case "sudo apt-get install lightdm" will re-install the Ubuntu default desktop manager. You should be able to login from the black screen, try pressing "enter" to see if it makes the text appear. If you still don't see anything then press "control + alt + F2", and then press "enter".

Lightdm = Ubuntu Desktop Manager (sudo apt-get install lightdm)

xfdesktop = Xubuntu Desktop Manager (sudo apt-get install xfdesktop4)

Gdm = Gnome Desktop Manager (sudo apt-get install gdm)

KDM = KDE Desktop Manager (sudo apt-get install kdm)

share|improve this answer
    
Thank you for the response but this doesn't seem to have fixed it. I'm still getting a black screen and I even tried reinstalling lightdm and ubuntu-desktop. –  user1147964 Feb 23 at 19:31
    
were you able to login from the blackscreen? –  mango Feb 23 at 19:32
    
Mango, seriously, did you read the op? Is this just some setup from you spammers? Such a weird conversation. –  henry Feb 23 at 19:33
    
I successfully logged in by doing control + alt + F2 and logging in through the command line. –  user1147964 Feb 23 at 19:34
    
I don't know what an "OP" is, but I gave instructions for logging in and I'm not sure if that portion worked. I'm trying to figure exactly which part of my instructions aren't working. –  mango Feb 23 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.