Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I got a Nvidia GTX 750ti for my htpc (ubuntu headless 12.04) but the computer wont boot with it installed. I've tried booting with nomodeset parameter and installing the latest beta driver from nvidia but I get black screen on boot. The machine does not seem to boot as I cannot ssh into it or invoke ctrl-alt-f*

share|improve this question
    
What driver are you using? nvidia-current –  the_Seppi Feb 23 at 17:30
    
Any reason not to mark Leonardo's answer as the accepted one? It worked for me, and it seems that for others too. –  canotto90 Nov 15 at 15:29

4 Answers 4

I have ubuntu 13.04 64 bit and same problem: Nvidia GTX 750ti and no boot.
I solve by following these steps:

  1. go on nvidea driver download I have get NVIDIA-Linux-x86_64-334.21.run
  2. put it in a folder you remember (your home) and make it executable (chmod u+x ./NVIDIA-Linux-x86_64-334.21.run)
  3. sudo apt-get purge nvidia*
  4. sudo apt-get purge xserver-xorg-video-nouveau
  5. sudo gedit /etc/modprobe.d/blacklist.conf or sudo vim /etc/modprobe.d/blacklist.conf
  6. add at the end this lines

    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv

    and save

  7. sudo gedit /etc/default/grub or better if you like vim: sudo vim /etc/default/grub

  8. find

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

  1. sudo update-grub
  2. now you have to go text-only:

    use CTRL+ALT+F1 to go on text-only
    to come back on graphic mode use CTRL+ALT+F7

  3. sudo gdm service stop or sudo service lightdm stop

  4. sudo sh ./NVIDIA-Linux-x86_64-334.21.run
    1. it give you some warning on pre build script I have continued
    2. it ask you to accept some condition, you give all yes
    3. let it change xorg.profile for you
  5. sudo reboot

if you have trouble at reboot you can do a new reboot and start in recovery mode:

  1. Advanced options
  2. recovery mode

after this if you continue by the normal boot you can login in graphical mode but after you are logged in you have to repeat step 7,8,9

at next login you can boot on graphical mode.

this procedure has worked for me I hope work for you too.

regards

share|improve this answer
    
+1 I had no graphics card in my system (using integrated graphics), then I installed an NVidia GTX 750 ti and Ubuntu would not go past grub. My Windows was still functioning fine so I knew it had to be the graphics card. This solution fixed everything for me, thank you! –  John Jun 11 at 6:15
    
Thank you so much! It's working now! I followed this steps but using a newer driver version "NVIDIA-Linux-x86_64-340.58.run" and it worked right after rebooting. 2 things to share: 1. after excecuting CTRL+ALT+F1, I could only see a black screen, so I had to shh from another machine to continue with the steps. 2. My problem was slightly different from the one described on this thread. I could use Ubuntu but at a very low res, and couldn't use any of the graphic card power. –  canotto90 Nov 15 at 15:27
    
work for me ! Thx –  Olivier Dec 7 at 3:05

I too have had some issues with the new Nvidia cards. Here's more commands that helped me.

boot in recovery mode with networking on.

navigate to your home directory.

cd /home

download Nvidia 750ti drivers... If you've got a different card, like a 760ti or 780ti check Nvidia's website when you go to download the driver, the 'Agree and Download" button is the link I used for the wget command below. If the drivers are different, (I don't think they are) this may solve some issues for others as well.

sudo wget http://us.download.nvidia.com/XFree86/Linux-x86_64/334.21/NVIDIA-Linux-x86_64-334.21.run

Then continue were Leonardo left off above. Thanks man, I'd +1 if I could.

share|improve this answer

After booting with nomodeset and installing ubuntu then only follow step 7 & 8 from Leonardo Saracini

then add following ppa;

sudo apt-add-repository ppa:xorg-edgers/ppa

sudo apt-get update & upgrade

sudo apt-get install nvidia-337 ( dont install that before command above)

restart and voila ;) (by the way I'm using 14.04)

share|improve this answer

This can be fixed by going:

  1. into recovery mode
  2. enable networking [on],
  3. go to root shell, type cd /home
  4. then sudo apt-get install nvidia-331 nvidia-settings
  5. then sudo reboot and you are done.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.