Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to upgrade gcc-4.8.1 and g++-4.8.1 to 4.8.2. I added the PPA containing g++-4.8.2, ran apt-get update and then when I try:

martin@martin-Studio-1537:~$ sudo apt-get upgrade
[sudo] password for martin: 
The following packages have been kept back:
  cpp-4.8 g++-4.8 gcc-4.8 gcc-4.8-base libasan0 libatomic1 libgcc-4.8-dev
  libgcc1 libgcc1-dbg libgfortran3 libgomp1 libitm1 libquadmath0
  libstdc++-4.8-dev libstdc++6 libstdc++6-4.8-dbg
0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.

the packages I need to upgrade are kept back. When I try:

martin@martin-Studio-1537:~$ sudo apt-get dist-upgrade
The following packages will be REMOVED:
  g++-4.8 gcc-4.8
The following packages will be upgraded:
  cpp-4.8 gcc-4.8-base libasan0 libatomic1 libgcc-4.8-dev libgcc1 libgcc1-dbg
  libgfortran3 libgomp1 libitm1 libquadmath0 libstdc++-4.8-dev libstdc++6
14 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Need to get 14.9 MB of archives.
After this operation, 32.4 MB disk space will be freed.

the system wants to remove g++-4.8 gcc-4.8.

When I try to install gcc-4.8 from Synaptic It wants to remove g++-4.8 and when I tell that it is ok to remove it, I get this error:

enter image description here

How can I install gcc-4.8.2 and g++-4.8.2?


As souravc suggested, I did

martin@martin-Studio-1537:~$ dpkg -l | grep "^rc" | awk '{print $2}'

and this is the result:

share|improve this question
possible duplicate of Can't install gcc 4.8, dependency issues – Registered User Feb 23 '14 at 5:27
@adityapatil It is not a duplicate. I read that question and did not solve my problem. If you see the solution in one of the answers, could you please post it as the answer to this question? – Martin Drozdik Feb 23 '14 at 5:36
Have you tried all solutions? or at least those who are upvoted? Also read this. – Registered User Feb 23 '14 at 5:37
@adityapatil Those are not solutions to the problem I am solving. – Martin Drozdik Feb 23 '14 at 5:43
try installing thrugh terminal using the options -fm. – Registered User Feb 23 '14 at 5:48

2 Answers 2

up vote 3 down vote accepted

gcc 4.8.2 is currently under development and will only be released for trusty(14.04LTS).

The current latest version available for Ubuntu 13.10 saucy is 4.8.1 and it will not be updated to 4.8.2

share|improve this answer
For anyone needing explanation, read this discussion. – Registered User Feb 23 '14 at 9:06
Could you summarize the discussion instead and add it as answer? – Braiam Feb 26 '14 at 20:46

You are getting this message as you have broken packages in your system. To be sure try this in your terminal,

dpkg -l | grep "^rc" | awk '{print $2}'

You should get a list showing above packages.

Run the following in a terminal to get rid of this,

sudo apt-get autoremove
sudo apt-get autoclean

To install gcc-4.8 and g++-4.8

sudo apt-get update
sudo apt-get install gcc-4.8 g++-4.8
share|improve this answer
Thank you, but I still get the same results. Moreover the list of packages I get (see my edit) is not the same as the ones I am trying to upgrade. – Martin Drozdik Feb 23 '14 at 7:05
@MartinDrozdik there was a typo. sorry for that. did you run those autoremove and autoclean commands? are you still getting the notice when going to apt-get update? – souravc Feb 23 '14 at 7:57
Yes, I typed the commands without the typo and it still doesn't work – Martin Drozdik Feb 23 '14 at 7:58
@souravc come here… – Avinash Raj Feb 23 '14 at 7:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.