Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install gtk-server. First I typed the command ./configure and then make, but when I typed command make install it gave me this error:

osama@osama-HP-Compaq-6910p:~/Downloads/gtk-server-2.3.1-sr$ make install
/usr/bin/install: cannot create regular file `/usr/local/bin/gtk-server': Permission denied
mkdir -p /usr/local/bin
/usr/bin/install -c gtk-server /usr/local/bin
/usr/bin/install -c stop-gtk-server /usr/local/bin
/usr/bin/install: cannot create regular file `/usr/local/bin/stop-gtk-server': Permission denied
make: *** [install] Error 1
share|improve this question

1 Answer 1

up vote 6 down vote accepted

If you are installing an application and used ./configure without the --prefix= option the make install process will install the compiled files in to the predefined paths in your system's file system.

Because you are installing to your system's file system you need special permissions for writing the files, try:

sudo make install

This will elevate your user's permission to root and allow the compiled files to be installed in directories that your user does not have permissions to do so.

You can clearly see that the issue is a permission problem by the error message (cannot create regular file cannot create regular file /usr/local/bin/gtk-server' and/usr/local/bin/stop-gtk-server'): the user that is trying to install these (in this case you) does not have permissions to write on those directories.

share|improve this answer
    
bruno it worked . i tried sudo make install. thanks –  osama Feb 22 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.