Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a newbie to ubuntu. I have installed Ubuntu 12.04 freshly onto my system and since then have been desperately been trying to get it to detect my wifi and connect to it. I have tried several approaches but none of them seem to have worked so far. Can someone please advise me on this? When I type in iwconfig i get :-

eth0 no wireless extensions

lo no wireless extensions

sudo lshw -C network gives :-

*-network
          description: Network controller
          product : BCM43228 802.11a/b/g/n
          vendor: Broadcom Corporation
          physical id :0
          bus info: pci@0000:02:00.0
          version: 00
          width: 64 bits
          clock: 33MHz
          capabilities: pm msi pciexpress bus_master cap_list
          configuration: driver=bcma-pci-bridge latency=0
          resources: irq:17 memory: d5300000-d5303fff
 *-network
          descriotion: Ethernet interface
          product: NetXtreme BCM5761 Gigabit Ethernet PCIe
          vendor: Broadcom Corporation
          physical id : 0
          bus info: pci@0000:0a:00.0
          logical name: eth0
          version: 10
          serial: b8:ac:6f:ca:be:2a
          capacity: 1Gbit/s
          width: 64 bits
          clock: 33Mhz
          capabilities: pm vpdmsi pciexpress bus_master cap_list ethernet physical
tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
     configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.132 frimware-5761-v3.78 latency=0 link=no multicast=yes port=twisted pair resources: irq:44 memory:d411000-d411ffff memory:d4100000-d410ffff

Please let me know if more information is needed.

share|improve this question
    
post the output of rfkill list. –  Avinash Raj Feb 22 at 17:56
    
Hi Avinash. It's not giving any output –  Sparky Feb 22 at 17:59
    
It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. No internet then go to this link for running the script without internet. [url]ubuntuforums.org/showpost.php?p=12350385[/url] –  Wild Man Feb 22 at 19:48
    
Hi Wild Man. Did that! Can you kindly go through the output and suggest what could be wrong? –  Sparky Feb 23 at 7:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.