Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had recent problems installing Ubuntu in my pc, sharing the disk with Windows 7. Mouse and keyboard weren´t recognized during the installation in 64 bit. I partially solved the problem when I found out that they were working in the USB 3.0 ports. Before this, I got desperated trying alternative ways of installing Ubuntu, which includes installing it with the Wubi utility and finally, from a LiveCD, overwritting this Wubi installation. Current situation looks like that: Ubuntu starts perfectly after grub, no problems here. If I select Windows in grub, it takes me to the Windows boot manager which appeared after using Wubi. It gives me 2 options: Windows and Ubuntu. When I choose Windows, the Windows loading screen appears for few seconds, flashes a blue screen and reboots. I'd appreciate any help with this, cause I am "a bit" lost.

EDIT: I've already tried Startup Repair with the Windows installation cd and the commands bootrec /fixmbr and bootrec /fixboot in the command prompt with identical results.

share|improve this question
    
Have you tried repair your computer option using Windows cd ? –  g_p Feb 22 at 14:43
    
Yes, I mention it now in the EDIT. Same results. –  Jorge Palomo Feb 22 at 14:54

2 Answers 2

up vote 2 down vote accepted

Some systems are known to have issues with the windows installation if a 64bit ubuntu is installed alongside. Using a 32 bit version produces no problem. You can try the boot-repair iso to fix the dual boot screens.

https://help.ubuntu.com/community/Boot-Repair

Boot repair can fix most of the common problems with grub.

share|improve this answer
    
Thanks! So as I read, with this CD I will be able to do what mbiber suggested some minutes ago, without messing with code (which a noob like me really fears ^^) and in case it fails, I can obtain some kind of log or Boot-Info, so you guys can see what I destroyed and how, right? :) –  Jorge Palomo Feb 22 at 15:49
    
a 32 bit Operating System has a very low RAM limitation –  user251046 Feb 23 at 9:16
    
A 32 bit system cannot see more than 4GB. Not very difficult to live with. –  lonesword Feb 23 at 17:32
    
@user251046, no, it doesn't. –  psusi Mar 4 at 3:18
    
@lonesword, a 32 bit system ( with pae enabled, as all Ubuntu kernels do ) can see 64 GB, not 4. –  psusi Mar 4 at 3:18

This sounds like a Windows Loader problem. You should try to do Windows Recovery via the installation media.

More info on recovery can be found on Microsoft web site.

I would start with startup repair and see if it works first.

share|improve this answer
    
Thanks for your quick response. Sorry for not mentioning it. As it says now in the EDIT part, I've already tried that. And I obtain exactly identical phenomena: Grub -> Windows Boot Manager -> Windows loading screen -> blue screen -> auto-reboot. –  Jorge Palomo Feb 22 at 14:53
    
I'm guessing GRUB has installed it self to MBR. I'd delete the MBR and then do the windows repair again. Then later it's easy to reinstall GRUB. Use this command to delete the MBR code and leave partition table untouched: dd if=/dev/zero of=/dev/sda bs=446 count=1 But be very carefull with dd command. You can backup the MBR first to be sure: dd if=/dev/sda of=/home/$USER/sda-mbr.bin bs=512 count=1 –  mbiber Feb 22 at 14:59
    
Thanks again. So, for me to have it clear: dd if=/dev/zero of=/dev/sda bs=446 count=1 This will delete MBR but not the partitions. After that, I will use Windows cd and its Startup Repair. Finally, I will reinstall GRUB (which I ignore how to do it). But basically, is like that, right? –  Jorge Palomo Feb 22 at 15:35
    
Yes, that is about it. If you backup MBR first you should have no problems. Whatever you do after it can be reverted using that backup image. –  mbiber Feb 22 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.