Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Asus K56CB laptop with Intel HD Graphics 4000 and Nvidia GT740. I tried Bumblebee to use them both(normally I can use only the Intel card). I followed 5 steps at https://wiki.ubuntu.com/Bumblebee for 13.10. When I tried optirun firefox it gave me this error:

[ 159.824254] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 159.824357] [ERROR]Aborting because fallback start is disabled.

After that my laptop started to make a lot of noise and after a while it shut itself down because of overheating. I checked the file "xorg.conf.nvidia". When i executed lspci | egrep 'VGA|3D' it gave me these results:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 740M] (rev ff)

BusID for my Nvidia card in "xorg.conf.nvidia" was correct. But there was no lines about Intel card so I added these lines:

Section "Device"
Identifier  "Intel"
Driver      "intel"
VendorName  "Intel Corporation"
BusID "PCI:00:02:0"
Option "ProbeAllGpus" "false"
Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
EndSection

After all of these, I rebooted my laptop and nothing changed. It still gives me the same error then starts heating. I'm searching for weeks and I couldn't find any working solution. Does anyone have a working solution? I don't know much about Ubuntu and Linux I've just started using them so if you have a solution, I would be really happy if you could explain it in basic steps.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.