Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Ubuntu... So pls ppl I need help :) My notebook specs :
CPU: Intel Core i5 3230m
RAM: 4gb 1600mhz
I have 2 gpus,
1st : Intel HD 4000
2nd : Nvidia GT 720m
Today i installed bumblebee and nvidia 331 driver. The install was successful so notebook started without black screen :) The problem is that notebook won't start programs with nvidia. And it won't recognize gpu :( Here what i did:

sudo apt-get install nvidia-331 bumblebee linux-headers-generic

sudo gedit /etc/bumblebee/bumblebee.conf

Replaced matching keywords with these values:

Driver=nvidia
KernelDriver=nvidia-331
LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331
XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules

Save and exit

I then removed 304-driver

sudo jockey-text -d kmod:nvidia_304

Then reconfigure some stuff, by running this and pressing ok.

sudo pam-auth-update --force

Rebooted.

Then i installed VirtualGL http://sourceforge.net/projects/virtualgl/files/VirtualGL/2.3.3/

sudo dpkg -i virtualgl_2.3.3_amd64.deb

After running optirun, here is the output :

nikola95o@nikola95o-X550VC:~$ optirun -vvv glxgears
[ 2454.183529] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 2454.184219] [DEBUG]optirun version 3.2.1 starting...
[ 2454.184240] [DEBUG]Active configuration:
[ 2454.184248] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 2454.184255] [DEBUG] X display: :8
[ 2454.184261] [DEBUG] LD_LIBRARY_PATH: 
[ 2454.184267] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 2454.184273] [DEBUG] Accel/display bridge: auto
[ 2454.184279] [DEBUG] VGL Compression: proxy
[ 2454.184285] [DEBUG] VGLrun extra options: 
[ 2454.184291] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 2454.184340] [DEBUG]Using auto-detected bridge virtualgl
[ 2454.187518] [INFO]Response: No - error: Could not load GPU driver

[ 2454.187546] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 2454.187555] [DEBUG]Socket closed. [ 2454.187582] [ERROR]Aborting because fallback start is disabled. [ 2454.187595] [DEBUG]Killing all remaining processes.

With lspci -v | less :

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core process
or Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 124d
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at f7400000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at  [disabled]
        Capabilities: 
        Kernel driver in use: i915

01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] (rev a1) Subsystem: ASUSTeK Computer Inc. GeForce GT 720M Flags: bus master, fast devsel, latency 0, IRQ 16 Memory at f6000000 (32-bit, non-prefetchable) [size=16M] Memory at e0000000 (64-bit, prefetchable) [size=256M] Memory at f0000000 (64-bit, prefetchable) [size=32M] I/O ports at e000 [size=128] Expansion ROM at f7000000 [disabled] [size=512K] Capabilities:

And here is my Bumblebee.conf file :

# Configuration file for Bumblebee. Values should not be put between quotes

Server options. Any change made in this section will need a server restart

to take effect.

[bumblebeed]

The secondary Xorg server DISPLAY number

VirtualDisplay=:8

Should the unused Xorg server be kept running? Set this to true if waiting

for X to be ready is too long and don't need power management at all.

KeepUnusedXServer=false

The name of the Bumbleblee server group name (GID name)

ServerGroup=bumblebee

Card power state at exit. Set to false if the card shoud be ON when Bumblebee

server exits.

TurnCardOffAtExit=false

The default behavior of '-f' option on optirun. If set to "true", '-f' will

be ignored.

NoEcoModeOverride=false

The Driver used by Bumblebee server. If this value is not set (or empty),

auto-detection is performed. The available drivers are nvidia and nouveau

(See also the driver-specific sections below)

Driver=

Directory with a dummy config file to pass as a -configdir to secondary X

XorgConfDir=/etc/bumblebee/xorg.conf.d

Client options. Will take effect on the next optirun executed.

[optirun]

Acceleration/ rendering bridge, possible values are auto, virtualgl and

primus.

Bridge=auto

The method used for VirtualGL to transport frames between X servers.

Possible values are proxy, jpeg, rgb, xv and yuv.

VGLTransport=proxy

List of paths which are searched for the primus libGL.so.1 when using

the primus bridge

PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus

Should the program run under optirun even if Bumblebee server or nvidia card

is not available?

AllowFallbackToIGC=false

Driver-specific settings are grouped under [driver-NAME]. The sections are

parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-

detection resolves to NAME).

PMMethod: method to use for saving power by disabling the nvidia card, valid

values are: auto - automatically detect which PM method to use

bbswitch - new in BB 3, recommended if available

switcheroo - vga_switcheroo method, use at your own risk

none - disable PM completely

https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

Section with nvidia driver specific options, only parsed if Driver=nvidia

[driver-nvidia]

Module name to load, defaults to Driver if empty or unset

KernelDriver=nvidia-331 PMMethod=auto

colon-separated path to the nvidia libraries

LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331

comma-separated path of the directory containing nvidia_drv.so and the

default Xorg modules path

XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

Section with nouveau driver specific options, only parsed if Driver=nouveau

[driver-nouveau] KernelDriver=nouveau PMMethod=auto XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

If you need something else just ask... Thanks ! :) And sry for my bad english :)

share|improve this question

1 Answer 1

I had this problem in debian, changing

Driver= to Driver=nvidia

and

KernelDriver=nvidia to KernelDriver=nvidia-current

and then restarting bumblebeed fixed the problem. Hope it will help. Anyway, check the name of your driver

ls -l /lib/modules/`uname -r`/nvidia/

and try to set it to your bumblebee config.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.