Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was installing utorrent server in my Ubuntu 12.04.4 LTS and appeared the following error:

utserver: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.16' not found (required by utserver)

So, I've started to search in Web to a solution, I tried for some hours and I didn't got my goal.

My Glibc is 2.15

ldd --version
ldd (Ubuntu EGLIBC 2.15-0ubuntu10.5) 2.15

I installed the following packages

apt-get install gcc gawk g++ build-essential linux-headers-`uname -r`

One of this tries was to download the library and install.

mkdir /catbed/ && cd /catbed/

wget https://launchpad.net/ubuntu/+archive/primary/+files/eglibc_2.16.orig.tar.xz

tar -xJf eglibc_2.16.orig.tar.xz

mkdir /catbed/glibc-build && cd /catbed/glibc-build

/catbed/eglibc-2.16/.configure --disable-sanity-checks

make

make install

Unfortunally I didnt got success, I want to paste my config.log here but the body is limited to 30000 characters.

Can anyone help me to update this glibc to 2.16 or 2.17 ???

## EDIT

In this thread : libc.so.6: version `GLIBC_2.16' not found

@Barafu Albino said:

There is a much safer way to run a single app. Problem is: while glibc is meant to be backwards-compatible, it is not 100% accurate. Issues are known. So, do not update the library system-wide. Instead, prepare a whole set of updated libraries. Put them in, say, /catbed. Then just run

/catbed/ld-linux.so.3 --library-path=/catbed:/whatever-else /usr/bin/python -python-args

Of cause, adapt the filenames to your case. This is much safer way to go, because if you mess up your system ld-linux+libc pair you will not be able to fix it from inside the OS. You will have hard times even chrooting into it then. I routinely use the trick for old proprietary Linuxes (gcc 3.1, kernel 2.3) on which I want to run Qt5.

But unfortunally I didn't understood what this mean or how to reproduce in my computer, can anyone explain me that?

-- EDIT -- The application that I was installing now have a version that supports Ubuntu 12.04.4 that don't require glibc 2.15.

share|improve this question
1  
    
I already read that, but I Did not understood how to do that: /catbed/ld-linux.so.3 --library-path=/catbed:/whatever-else /usr/bin/python -python-args –  André Faria Feb 22 at 14:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.