Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 11.04 and discovered that my video card (a GeForce Go 7400) was blacklisted.

I can live without Unity but some of the other Compiz features, that I depend on, are also unavailable -- the most important being placing windows with the grid plugin, and the most satisfying being the cube rotation.

I have no idea why the former would be affected by my graphics card. I have tried forcing Unity (using the environment file) but it crashes as the Unity scholars promised. I have also switched to another driver (173, I believe) but that also has made no difference. Lastly, I reset Compiz back to its defaults. Nothing has worked. What else can I try? (Thanks.) (@Jorge: Thank you for the formatting assist.)

UPDATE: In searching for Compiz alternatives, I figured that I could set up Metacity to handle the window management. In so doing, I realized that Metacity had already become the default window manager, which explains why none of my Compiz settings are having any effect. The real problem, then, is that I can't run Compiz. Using "Compiz --replace" freezes the screen. Now that I have the equivalent of the grid functionality, I might stop while I'm ahead. Of course, that would be the first time I have ever stopped while I was ahead.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

the nvidia go 7300/7400 were blacklisted due to some issues. here is how to solve the problem. first, install the nvidia 173 driver or the experimental drivers. (if you uninstall the nvidia and reboot, you should see the experimental one suggested in the list). second, open a terminal, type " sudo nautilus ", go to file system, etc, enviroment. third, open the file, and add this line at the bottom " UNITY_FORCE_START=1 ". without quotes. then save and reboot to ubuntu session. you should see now unity. if not go to ccsm and enable the unity plugin. reboot and your issue is solved. see reference Geforce Go 7300/7400 blacklisted, can I still run Unity?

share|improve this answer
    
Thank you for taking the time to reply. I appreciate it. Using "lspci -v", I confirmed the correct card+driver. I saw "VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1)" and "Kernel modules: nvidia-173, nvidia-current, nouveau, nvidiafb". And, I added "UNITY_FORCE_START=1" to "etc/environment". If, upon startup, I select "Ubuntu", the system stops on the default wallpaper (the one with the flared lights) and the pointer returns to an arrow but nothing else appears. If I choose "Ubuntu Classic", the system stops on my wallpaper and also remains blank. –  Lee B. May 14 '11 at 5:53
    
yes but which driver is in use? try to log in low graphics mode. select the right driver in the gui. nvidia 173. enable the unity plugin in ccsm and reboot. –  suli8 May 14 '11 at 11:14
    
Answering this post is my first official act with Unity running. (@suli8: Thank you very much.) For those who know as little as I do, I selected Additional Drivers and saw that 173 was listed but not active. (I could have sworn there was nothing listed in that window before). Restarting the computer and logging in, revealed what appeared to be a blank screen. I noticed that I could use key equivs to flip workspaces, so I started a terminal, typed ccsm (for Compiz), and activated the Unity plugin. (@suli8: Thanks again.) –  Lee B. May 14 '11 at 17:14
    
you welcome mate! enjoy! –  suli8 May 14 '11 at 18:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.