Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I usually get this alert each time i start my Ubuntu that i should perform software

update, i usually ignore it. but yesterday i just decided to perform the update which

couldn't complete because my internet connection got so slow and disconnected. since then

just after i shutdown my system its being showing some black screen just after the Ubuntu

logo is done loading.

i even inserted the Ubuntu disc and tried to run from CD but just after the Ubuntu logo is

done loading i get a black screen.

share|improve this question

1 Answer 1

Try to reboot in recovery mode. I believe one of the options available is finish package configuration.

If you are able to get to a command prompt at all, the command to do that is:

sudo dpkg-reconfigure -a

If you need to get to a virtual terminal, Ctrl-Alt-F1 or Ctrl-Alt-F2 should get you there. Even if your Xorg.conf is hosed, you should (hopefully) see some 80 column text on VT1 or 2.

You may have to run

sudo apt-get safe-upgrade

To finish getting all of the updates. After that:

sudo apt-get dist-upgrade

To get any update dependencies knocked out. And then

sudo reboot

When finished.

share|improve this answer
    
thanks for that @the dude. I run the command you gave but after pressing Ctrl-Alt-F1 i got a command prompt then i did the sudo command up there here is what i got; sudo:effective uid is not 0, is sudo installed setuid root?. Any idea dude? –  cyril paul Feb 21 at 18:11
    
@cyrilpaul edited in more advice. –  The Dude Feb 21 at 18:14
    
still same error ; sudo:effective uid is not 0, is sudo installed setuid root? –  cyril paul Feb 21 at 18:26
    
it appears i cant run any sudo command at all –  cyril paul Feb 21 at 18:37
    
That sounds bad. Like sudo was being updated at the moment you shut down. Any chance you can reboot and drop into the recovery console? Once there, you can run those commands above without the sudo. –  The Dude Feb 21 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.