Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Dell Inspiron 15 came with a pre-installed Ubuntu 12.04. Now I want to remove that and replace it with Windows 8.1 (Enterprise) and Unbuntu 13.10.
I have created two bootable USB sticks for both of these OS.

When I search for this kind of scenario it always leads me to this question:
How to remove Ubuntu and put Windows back on.
But this is not my question, as I don't have any Windows on my PC currently.

Following is what I tried:

enter image description here enter image description here enter image description here enter image description here enter image description here

?? Clueless from here for what to do ??

I tried to format one of the partitions myself which named as OS (3.2 GB). I know that possibly I have done some harm, but it has happened. Now that partition is named as "Primary" (as seen in the image above).

Now sometimes when I switch on my PC, it gives me an error "No Media found". But half of the time it boots to the Ubuntu as it was happening earlier!

So my main goal is:

  1. Uninstall the Ubuntu 12.04 completely (this came by default)
  2. Clean install Windows 8.1 Enterprise
  3. Dual boot the same with Ubuntu 13.10

The 1st step is the most crucial. Help would be appreciated.

share|improve this question
    
ignore ubuntu and just install windows then Ubuntu. Skip step one. –  Alvar Feb 21 at 6:15
    
@Alvar, this is not happening. I am not reaching till the option where it just does it. It shows some partitions and says that Windows is not compatible with such partitions. –  iammilind Feb 21 at 6:16
    
then use gparted and remove it. –  Alvar Feb 21 at 6:16
    
@Alvar, see the updated question. Do I need to delete all the partitions. Right now the "Delete" option is available for all the partitions except the last one (Drive 1 Partition 1: IR1_CENA_X64FREV_E). Or still I need to use Qparted? –  iammilind Feb 21 at 6:39
    
Boot Ubuntu live disk and then click on try Ubuntu.Open gparted from dash, take a screenshot and then post it here. –  Avinash Raj Feb 24 at 5:46

4 Answers 4

I'm not clear what is the problem with fresh Windows 8.1 installation on your system. You should be able to create/delete partitions during installation.

In case, you don't have that option then use any other OS install image/CD to delete the Ubuntu 12.04.

Remember to create total of 3 partitions excluding DELLUTILITY partition. One NTFS for Windows 8.1, one later, ext4, for Ubuntu and on for swap.

Hope this helps..

share|improve this answer
    
I have updated the question with some of the images, which shows what I tried. Do I need to delete all the partitions shown in the last image? Right now the "Delete" option is available for all the partitions except the last one (Drive 1 Partition 1: IR1_CENA_X64FREV_E). –  iammilind Feb 21 at 6:37

I would have done it in the following way:

1) Boot an Ubuntu Live Disk (or any other which contained GParted).

2) Remove/modify partitions I did not need using GParted.

3) Create partitions as I want.

For example a 100gb ntfs partition for Windows, a 50gb ext4 50gb partition for Ubuntu, and other data partition(s) as required.

Alternatively one could just create a ntfs partition for Windows, and choose the "Install alongside Windows" option while installing Ubuntu which would automatically partition for Ubuntu.

4) Install Windows to my created ntfs partition.

5) Install Ubuntu.

Link: How do I repartition with GParted?

share|improve this answer
    
Giving bounty to this answer for decent writing. –  iammilind Mar 1 at 6:27
up vote 1 down vote accepted

I finally fixed on my own.
As shown in the last screenshot (5th one), I deleted the partitions which are named as:

  • Driver 0: Partition 2
  • Driver 0: Partition 4

After that, it allowed me to install the Windows 8.1 on

  • Driver 0: Partition 4

Still I missed to connect with the internet while the installation was going on. Probably due to which I am not seeing many drivers (like wireless) and right now struggling to getting the things right.

From the Dell support, I installed the drivers for wifi and Bluetooth. Now it's working fine. I had already created a partition for Windows. Hence my Ubuntu 13.10 installation was straight forward. Now everything rocks!

share|improve this answer
    
From your answer it sounds like you only installed Windows, so how did you "fix it on your own"? Do you also have Ubuntu installed? Your answer doesn't mention it. –  bigbadonk420 Feb 25 at 18:02
    
@bigbadonk420, I had an Ubuntu inside the my PC. I installed Windows 8 (removing old Ubuntu 12.04) and then Ubuntu 13.10 both one by one. –  iammilind Feb 28 at 5:46

I faced same problem with my Lenovo 430c thinkpad. follow following steps 1) enter into the Bios and disable efi boot and change it to support legacy boot (perhaps terms may be different but something like that which is used to protect your built-in OS) 2) first install windows but leave some disk space with out formating keep it in raw shape. this will be detected by Ubuntu when you start its setup 3) after installing windows you can now install Ubuntu I a way you like recommended by DVD?CD. 4) if ubuntu ask for boatloader preference use Ubuntu loader it is reliable in dual boat.

I hope this will solve your problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.